16

I installed Kali Linux OS on my hard disk and set nothing as username and password. Now at the time of login it ask for localhost username and password. I tried root and toor as default but didn’t worked for me.

  • How exactly did you install it? If you're not using a LiveCD, then you were supposed to be asked to set the password during install. See docs.kali.org/frequently-asked-questions – Ƭᴇcʜιᴇ007 Jul 13 '13 at 14:01
  • @techie007 : At the time of installation, I haven't provided with any password. But anyway I solved the problem by resetting the root password via shell.Thanks anyway. – wek Jul 13 '13 at 14:42
33

I had the same issue. However I did remember entering a password and most default username for Debain flavors are root.

So try:

  • Username: root
  • Password: toor (or the password you entered at installation)

Kali Linux Default root Password is toor

Default root Password

During installation, Kali Linux allows users to configure a password for the root user. However, should you decide to boot the live image instead, the i386, amd64, VMWare and ARM images are configured with the default root password – “toor“, without the quotes.

Source Kali Linux Default Passwords

  • 4
    Yes, just use root and the password you used... Thank you @Benjamin – Mário Carvalho Feb 22 '14 at 20:07
3

I went to boot menu and selected the “recovery mode.” There I used passwd command to set new credentials to my root account.

2

Just encountered the same problem with a fresh Kali Linux install. I chose to disable root login, and create a user account instead. Don’t remember giving a root password

But here’s an easy workaround to jump straight into a root-shell without the password:

sudo su -

simple as that, now you’re free to change your root password:

passwd
1

I had the same problem but tried something else. If you entered the root password at the beginning of installation then enter root as the user, and the root password you entered at the start of installation. That should work.

1

I thought I had plugged in my username as kali during the installation, but it turned out that I had to use root as the username. The password was the one I set though.

protected by Community Sep 21 '14 at 18:12

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.