I have an external HD that I want to format. The disk doesn't appear in the device list, neither in xp, nor in Windows7. Here's what I did so far:

  • Ubuntu: Ubuntu sees it but I can't mount it, nor format it, I've tried many times. Gives me an error every single time, besides It's listed in disk management but not in gparted.

  • Windows 7: The 'initialize disk' option under 'disk management' in windows 7 is greyed out so it's useless. Same for format, diskpart, scandisk, defrag, etc. I can't do anything via cmd because windows can't see the hd.

  • External Software: Acronis Disk Director sees the disk, the column on the left says 'initialize disk'. I click ok. But the operation stops middway because of an error. It says the disk is write-protected.

  • So I downloaded usb writeprotector by gaijin and here's the thing: it worked the first time. I was able to remove the protection, initialize the disk with acronis, it appeared in the device list so I could format it and then re-load backed up data on it. I safely removed it in the evening but when I connected it again in the morning it was gone again.

Back to square one. I re-did all I did the first time but somehow it doesn't work anymore. I even used a different software instead of usb writeprotector (tried USB Disk Manager) but no luck. I'm sure it's the disk and not my computer because it behaved the same way on three different machines.

The disk is not mine so I don't know what the did on it, I don't care about the data on it because I have a backup of everything. I just want to be able to use the disk again (just maybe not as an external backup drive because I don't trust it that much now)

Oh, and I gave it to a friend to see if he could disassemble it and attach it directly inside his comp but he says it's neither IDE, nor SATA so he can't do anything.

  • Sounds broken. What's your question? – Ƭᴇcʜιᴇ007 Jul 15 '13 at 13:41
  • The one in the title. How can I format a protected disk (taking into consideration what I explained in the post) – Barbara Jul 15 '13 at 13:43
  • It sounds like the disk is somehow marked as read-only. Is this a thumb-drive? an external hard drive? ??? A few external thumb-drives have a write-protect switch on the someplace. You may want to check with the manufacturer of the drive/enclosure/whatever it is... and see if they provide a software utility to lock or unlock the drive. – TheCompWiz Jul 15 '13 at 13:52
  • @TheCompWiz it's an external hd with no write-protect switch. It's this one. – Barbara Jul 15 '13 at 13:55
  • @Barbara That looks like it's only the enclosure. What specific hard disk make and model is installed in it? – a CVn Jul 15 '13 at 14:11

If your external drive is formatted using "ExFAT", you may have some corruption. (or at least, some OS has marked it as corrupted.) Have you tried running an fsck or CHKDSK on that drive? ExFAT switches volumes to read-only on the fly if it detects corruption.

| improve this answer | |
  • When I formatted it the first time I selected NTFS. I didn't run CHKDSK because I thought formatting would be enough. I can't run CHKDSK now because the drive has no letter assigned. Here's the screenshot from Acronis for reference i.imgur.com/gL7ZakW.jpg – Barbara Jul 15 '13 at 14:20
  • Acronis is not running Windows. It is linux. Regardless, the screenshot tells me nothing more than it could not find a valid partition table. (uninitialized disk) It sounds like the drive has failed, and/or the external adapter (enclosure?) is broken. – TheCompWiz Jul 15 '13 at 15:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.