3

If i apply a dark theme in Notepad++ the cursor stays black and therefore the cursor disappears when it shows as textmarker into the background.

Is there an options for changing that?

In sublimeText2 the text cursor is white.

Image: (http://msdn.microsoft.com/dynimg/IC210312.png)

7

Yes, settings - styler configurator - global styles - carat colour

Edit

To include discussion below, this changes the carat, not the mouse pointer or cursor as those are handled by the OS.

pointers

  • That is the carat that shows where you would input text, not the cursor you move with your mouse. – Kevin Simper Jul 16 '13 at 10:48
  • The mouse pointer settings are based on the OS – Raystafarian Jul 16 '13 at 10:52
  • But in SublimeText2 they have made the cursor white? If that is the case, I find it strange that you would choose a dark theme in Notepad++. – Kevin Simper Jul 16 '13 at 11:20
  • @KevinSimper my mouse is the same in both sublimetext2 and notepad++ as well as all my other windows. I'm using Windows Black (system scheme), which is a black mouse (pointer, cursor) with white outline. The outline shows up better on dark windows than light windows. – Raystafarian Jul 16 '13 at 11:27
  • @KevinSimper as seen here – Raystafarian Jul 16 '13 at 11:37
2

This is due to the OS. Go to 'mouse pointers' in Control Panel, click on the 'text select', then 'browse', and choose 'beam_r'

  • Now available is beam_rm and beam_rl for even larger cursors. Alternatively consider any of the large or extra large pointer schemes. – Laurie Stearn Jun 25 '18 at 15:01
1

I went to control panel and to the mouse where there is an option for additional items. I clicked on the pointer and changed it to black. At least I can see that when it is in notepad

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.