I really love git gui and gitk. They work very well for me and I know exactly how to use them. Sadly, they look really pixelated and ugly on my retina macbook. Since it's just text and chrome it would seem on the outset a fairly simple thing to fix. But I've looked around quite a bit for a solution and I haven't found one.

Horrible pixelation

  • By pixelated and ugly, do you mean that there is no font anti-aliasing? I've never seen this application before. Is it based on TK or GTK+ ? – Ярослав Рахматуллин Jul 17 '13 at 14:56
  • 1
    No. As you can see there is a lot of anti-aliasing going on. I think you have to open up the image in full resolution to appreciate the horror. The application is apparently a Tcl/Tk application. – pius Jul 21 '13 at 22:54
  • You can post the update and accepted it as an answer. Also, out of curiosity, could you post an image of the program with the font fix applied? – Ярослав Рахматуллин Jul 22 '13 at 0:19
  • Done and done. Again, you probably have to open up the image in a separate tab to see it. When shown inline in the thread, it's hard to see the problem. – pius Jul 22 '13 at 1:22
  • 1
    Right, Apple removed these tools from their version of git. I installed git using homebrew: brew install git. – pius Feb 24 '16 at 13:47

You can also use Retinizer which I guess will edit the Info.plist for you.


open /System/Library/Frameworks/Tk.framework/Versions/Current/Resources/

Drag&drop Wish into Retinizer. Retinize. Voilà !

  • 4
    If homebrew caskroom is installed then: brew cask install retinizer – Joe Aug 26 '15 at 14:47
  • does not work, do I need to reboot? – logcat Mar 17 '16 at 9:54

The solution pointed by @patrick-browne works like a charm and it is simpler, in fact, given that I already did the another approach pointed by @pius too.

As @joe said, just install retinizer with brew cask, then drag Wish and drop into Retinizer:

  1. $ brew cask install retinizer

  2. $ open /System/Library/Frameworks/Tk.framework/Versions/Current/Resources/

  3. Drag Wish and drop into Retinizer

  • Worked! ... even if I was hoping for a less hacky solution. – sorin Aug 11 '17 at 12:51

Update August 28, 2013: The pull request I submitted has been accepted, so I expect the problem will be fixed at the source, hopefully in release 1.9. If you can't wait, follow the work-around presented below.

  1. Open your terminal and navigate to /System/Library/Frameworks/Tk.framework/Version/8.5/Resources/
  2. Use an editor to open the Info.plist file inside the Wish.app folder (I used sudo emacs Wish.app/Contents/Info.plist)
  3. Add the following two lines to the file, before </dict> and save it: <key>NSHighResolutionCapable</key>
  4. Make the OS reload the info file. This can be achieved with these commands:
    sudo cp -R Wish.app WishCopy.app
    sudo mv Wish.app WishOriginal.app
    sudo mv WishCopy.app Wish.app
  5. Try running open Wish.app to see if it worked. If it did, it should work for gitk as well.
  6. Do the same thing for git gui, but this time do it on the Git Gui.app (mine was in /usr/local/git/share/git-gui/lib/)

Oh, and I should probably mention that I found out about the NSHighResolutionCapable key from the tcl-mac mail-list, specifically from an e-mail by Kevin Walzer.

Here is a screenshot of the nice crisp fonts: Nice crisp fonts

  • A friend and I had a bit of disagreement about a "blurry font" in another application. I said that the font looked alright (similar to the first image) while he insisted that it was subpar. I see what he meant now. – Ярослав Рахматуллин Jul 22 '13 at 14:32
  • Thanks, I did find the.app -print0 | sudo xargs -0 touch instead of moving around and it worked for Wish. Though for git gui I had to go to finder's Get Info and toggle open in low resolution. – Michael Krelin - hacker Jan 2 '14 at 17:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.