2

I have a directory that I'm trying to cd into. It's a simple Rails app my friend built. The weird thing is, when I try to cd into it, the iTerm window closes. I've tried moving it from the directory it's in to the Desktop, but the same thing happens. I can run commands on the directory (like ls) from another directory, but cd'ing into the directory closes the window. I've never seen anything like it. How can I fix this?

  • Sounds like a shell issue. Dump the results of set. – Ignacio Vazquez-Abrams Jul 18 '13 at 3:11
  • It's quite a lot. Here it is on github as a gist – nickcoxdotme Jul 18 '13 at 3:15
  • Run unset rvm_fail and try entering the directory again. – Ignacio Vazquez-Abrams Jul 18 '13 at 3:17
  • Same thing. I also tried in normal Terminal with the same results. – nickcoxdotme Jul 18 '13 at 3:18
1

Inspired by @Ignacio Vazquez-Abrams's answer, I thought this might have something to do with rvm. I don't know why this would fix it, but when I cd'ed into that directory using Terminal (instead of iTerm), before it hung, it told me that I didn't have the version of Ruby installed that was used by this app. So I ran rvm install ruby-1.9.3-p448. This enabled me to successfully cd into that directory in both Terminal and iTerm2.

| improve this answer | |
  • It's still in bad taste for it to kill the shell in use though. – Ignacio Vazquez-Abrams Jul 18 '13 at 3:37
  • Oh, definitely. That's why I'd love to know how this is happening. – nickcoxdotme Jul 18 '13 at 3:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.