8

I have 2 monitors, unfortunately one is smaller than the other.

I want to use the 1920x1200 monitor for a fullscreen RDP session (this is where I do my main work).

And I would like to use the smaller (1280x1024) monitor on the side for email/skype/browsing etc.

The problem is that the RDP "fullscreen" resolution seems to be limited to the resolution of the monitor that I configured as my primary screen.

No problem, I thought, and configured my bigger screen as primary. But the problem with this setup is that the fullscreen RDP session hides my taskbar, and I miss email and skype notifications.

How can I have my taskbar display on my smaller screen, while still have a fullscreen RDP session on my bigger screen?

Edit: My current workaround is this: Make my bigger screen primary, start the RDP session, then make my smaller screen primary (not satisfactory at all).

4
  • This may sound stupid, but have you tried to drag the RDP Window to the bigger screen and maximize it there? Windows should, by default, maximize an application to the screen it's currently on.
    – who.knows
    Jul 18, 2013 at 6:40
  • 1
    Yes I did. When I click the maximize button, the rdp window just resizes to the resolution of my smaller primary screen (1280x1024). Jul 18, 2013 at 6:43
  • What about the resolution setting in the RDP "View" configuration tab, is 1280x1024 the maximum you can set there?
    – who.knows
    Jul 18, 2013 at 6:46
  • No, the last 2 settings are 1920x1200 and fullscreen. It is saved at fullscreen. Jul 18, 2013 at 6:48

8 Answers 8

9

The solution is to set the resolution in the view tab manually to that of your big screen (1920x1200 in this case), instead of "fullscreen".

This is due to the fact, that the initial RDP window always opens on your primary display and will take that display's current resolution as "fullscreen".

0
4

You can set ANY resolution you like by editing the .RDP file in a text editor!

2

Start the Open Remote Desktop connection, and drag the window to the bigger screen before you connect. This will open the desktop on that screen then, with the full screen size of that bigger screen.

1

Edit the RDP settings by right clicking the link. Go to the Display tab. Drag the slider off the Full Screen setting and you should see the highest resolution of your available monitors.

Save the settings.

1
  • Actually that is exactly not working for me, as described in my question. With the full screen setting I get the resolution of my primary monitor (even if it has the smaller resolution). Jul 24, 2013 at 6:10
0

Open up Remote Desktop Connection, then go into options on the bottom.

Then under Display there is an check box to "use all my monitors for the remote session".

May not be exactly what you want, but may help get more real estate.

0

If you are worried about not seeing new notifications showing up on the task bar because it is hidden behind the RDP session on the larger display, an alternate solution is to click anywhere there is an empty spot on the task bar and drag your task bar to the smaller monitor.

2
  • The fact that one of the answers was selected (the green checkmark) means that is has been resolved to the satisfaction of OP. It may be helpful for you to read the Help section, particularly the Tour, to learn how SU works and how to participate. Nov 8, 2018 at 22:06
  • Welcome to Super User, and thanks for trying to help with this question. Even after an answer is accepted by the OP, new solutions are still welcome. Just review what has already been contributed so as not to duplicate it. The site does work differently from a forum, so taking the quick tour and reading the posting guidelines (both accessed through the question mark icon at the top), will help you get the most from the site and make the most effective contributions.
    – fixer1234
    Nov 8, 2018 at 23:09
0

If you’re using Mac’s Microsoft Remote Desktop, edit the connection, go to Display, and check “Optimize for Retina displays”. Then reconnect.

-1

In Remote Desktop connection display tab, under display configuration section, move the cursor to required screen size (between small and large) and then click connect or if you have shortcut make the change and save it.

1
  • As you are new to superuser: A screenshot might help. Also the question is almost 5 years old, so maybe it's already solved. Feb 4, 2018 at 13:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.