I have two Seagate barracuda 7200.10 500 GB drives pulled from an old Lacie Big Disk Extreme. I have been using them both in a Dell Dimension 4600 in a master slave configuration, (one by default has a jumper as master and the other has no jumper as a slave. This is confirmed by this article)

I inherited an Optiplex gx620 and was attempting to set up the same configuration, but I have been having difficulties. When each drive is connected separately as master, they are detected and work perfectly. However, when connected in a Master/Slave relationship, neither are detected. This machine is equipped with the "cable select" feature, so I attempted that jumper configuration on the drives, but I had the exact same result. I have tried 3 different cables and nothing makes any difference.

Does anyone have any idea why this configuration isn't working?

Additionally, it should be noted that the PATA cable was originally connected to a DVD drive, and I'm reasonably sure that the original harddrive was on SATA with no PATA hd at all. I have changed the settings in the bios (A11) to disable all SATA, and enabled the two PATA connections.

Update: For my own sanity, I plugged both drives back into the original dimension 4600 and configured them as Master/Slave on a single IDE connector. Both drives were recognized and booted fine. I moved the exact same setup over to the new computer and it still didn't work. As a result, I'm inclined to believe this is a problem with the motherboard or BIOS.

Is there any sort of setting on the board that would cause this problem?

  • Are the disks on seperate controllers or attached to one cable on a single controller? – Scandalist Jul 19 '13 at 19:24
  • single cable, single controller – toppy42 Jul 19 '13 at 19:29
  • Please post the drive model numbers so they can be researched on the manufacturer's site. – Blackbeagle Jul 19 '13 at 22:27
  • Model Numbers: ST3500830A P/N: 9BJ036-500 Firmware: 3.AAC S/N: 9QG1QH7W 9QG18009 – toppy42 Jul 19 '13 at 23:02
  • Are you using an 80-pin cable? Does it have a twisted portion between the two drive connectors or not? Which drive is connected to the end of the cable? – David Schwartz Feb 6 '16 at 23:50

I have seen old IDE drives misbehave with jumper settings that should work. Cycle through all the possible settings on each of the drives: master/slave, master/CS, Slave/CS. Some drives have a master setting which is Master ONLY (no other drives allowed) and another jumper with master w/slave.

  • I suspect this may be the case, if it's master only and another drive is hooked up, I've seen this happen. – Taegost Jul 19 '13 at 19:38
  • On the harddrives, there is a sticker that gives a diagram for master, but next to it, it says "Master on, slave off". I was concerned that this may be shutting off the slave device like you are saying, but i've now tried master/slave, CS/slave, master/CS, CS/CS but to no avail. There are two more sets of pins that I might try to play with – toppy42 Jul 19 '13 at 19:48
  • 1
    "Slave Off" means no jumper should be set. Is that how you are reading it? – Scandalist Jul 19 '13 at 20:40
  • this is the instructions I'm working off of at this point. I was worried that setting the master to on would turn the slave off, but the documentation says otherwise – toppy42 Jul 19 '13 at 20:55
  • Yeah, so remove the jumper alltogether from the drive you want to slave and set jumper to that first set of pins on the master. – Scandalist Jul 19 '13 at 21:06

First confirm that the hard drives do not require different jumper settings for "Single/Master" and "Master with Slave Present." (Although in my experience, Seagate drives only have a single jumper setting for both cases.)

Make sure you don't have the cable plugged in backwards (i.e., with the wrong end plugged into the motherboard). The side of the cable with a red stripe should align with pin 1 of each connected device. The cable's connectors themselves also typically have an arrow pointing at pin 1.

It is also possible that the slave is disabled in the BIOS. Check the BIOS settings to confirm that none of the interfaces are set to "Disabled." For the Optiplex GX610, you'll need to go to the Drives menu and make sure Drive 0, Drive 1, etc., are not disabled.

  • The side connected to the harddrives has two connectors, while the motherboard side only has one. 2 of the 3 cords are cable select cords and the blue side goes into the motherboard, grey into slave, and black into master. I'm pretty sure they aren't backwards. I have both Pata (master and slave) enabled in the bios – toppy42 Jul 19 '13 at 19:39
  • To clarify, the red stripe I was referring to goes along the length of the ribbon cable, but it sounds like you have the cable oriented correctly. – rob Jul 19 '13 at 22:06
  • Does your motherboard have a single PATA connector, or does it have two? If it has two, have you tried installing both hard drives as Master on separate IDE interfaces? Do you have any other drives you can try instead of, and in combination with, each of these drives? Also, try swapping the power supply if you have another one you can test with, in case the power supply itself has degraded to the point that it cannot power both drives. – rob Jul 19 '13 at 22:13
  • Unfortunately, it only has one connector. I don't have any other pata drives to try. I just tried with a different power supply and it didn't have any effect. – toppy42 Jul 19 '13 at 22:20
  • Did you ever had PATA drives working on this motherboard ? I've got a nagging suspicion one of the pull-up resistors between the controller and connector is broken. That would account for this behavior. – Tonny Jul 19 '13 at 23:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.