52

How do you disable the bell sound in Intellij.

I am using the IdeaVim plugin for Intellij on Mac OS X and want to mute the sound.

100

This article may help you.

Basically, IdeaVIM reads your ~/.ideavimrc (~/.vimrc pre-v0.35) file and silently ignores any settings it does not understand. Of the bell-related settings, it does not understand :set noerrorbells, but it does understand :set visualbell. And since it has no implementation for a visual bell, it will do nothing and achieve the desired effect.

So in your ~/.ideavimrc, you can use the following:

set visualbell
set noerrorbells

This will set the (non-functional) visual bell for IdeaVIM while disabling the bell completely for VIM itself.

  • 1
    Note that as of v0.35, IdeaVIM no longer uses the ~/.vimrc, it now uses ~/.ideavimrc. – Andrew Lank Jun 17 '14 at 16:28
  • This is not working for me in IntelliJ 2018.2 and IdeaVim 0.50 on Windows 10 – Michael Dorst Nov 5 '18 at 3:32
  • 3
    on windows (7) it is _ideavimrc instead of .ideavimrc in your C:\Users\<username>\ folder – Chris Mar 11 at 21:04
4

I wanted to disable the Bell sound throughout all of my Mac, including AppCode. Did this by sliding Alert Volume to 0 in System Settings > Sound on my Mac

  • Blissful peace! Thanks :) – levacjeep Aug 29 at 15:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.