-2

I have a Toshiba Satellite S855 laptop with an RealTek RTL8723AE Wireless Networking card. My laptop runs Windows 7 Home Premium SP1.

For the past couple of days, my wireless internet speed has dropped drastically. It used to be ~18 Mbps, and is now between 1 and 2.5 Mbps. (All tests done with speedtest.net)

My friend's laptop has no such problem, nor do any of my other devices. It's just this PC that's driving me nuts.

I tried the following:

  • Restarted the PC (of course)
  • Tested wired connection vs Wireless (Wired showed true speed of 18 Mbps)
  • Uninstalled and re-installed the Wireless driver
  • Deleted the wireless driver, downloaded and installed fresh from Toshiba
  • Ran a total virus/malware scan using Kaspersky Internet Security 2013
  • Flushed DNS, tried ipconfig release/renew
  • Tried Google DNS (8.8.8.8/8.8.4.4)
  • Restarted/Reset the wireless router
  • Checked wireless speed from Ubuntu 13.04 (dual boot) - this gave me ~6 Mbps, but then, Ubuntu has always been a bit slow on Internet connectivity
  • Enabled Guest user profile and checked speed from the Guest profile - no improvement

I am literally at my wit's end now. It would be great if I get some help on this please!

--
TiA,
Ram

  • @Ramhound : I'm more than willing to supply any required information. Just let me know what you need! Thanks! – Ram RS Jul 23 '13 at 1:26
  • @Ramhound : Yes, but I was wondering how exactly to get that information. Anyway, here is what DriverFinder has to say about my Wireless Networking Card: Realtek RTL8723AE Wireless LAN 802.11n PCI-E NIC – Ram RS Jul 23 '13 at 3:57
  • Also, the driver is the latest version (at least according to Toshiba's support web site). The version is 2002.5.712.2012, dated 15-July-2012. – Ram RS Jul 23 '13 at 4:11
  • let us continue this discussion in chat – Ram RS Jul 23 '13 at 18:02
  • This question appears to be off-topic because it is about a very specific hardware combination and does not have an answer that can help others with the same problem in the future. – nhinkle Jul 31 '13 at 0:09
-1

Well, no idea how, but the issue resolved itself! Checked multiple times today and I had >=17 Mbps d/l speed!

Not the answer you're looking for? Browse other questions tagged or ask your own question.