I have a Chrome icon on my taskbar. If I left-click it, it glows as if to open, but then the glowing goes away and nothing happens. If I right-click it, then I can successfully open Chrome by clicking 'New window' or 'New incognito window' under 'Tasks'. [I'll add that the exact same problem occurs with Chrome's desktop icon, and with the Start menu's entry for Chrome. Neither will open unless you right-click and choose 'Open new window' or 'Run as administrator'.]

I suspected it had something to do with a more general problem, where Windows 8 refuses to treat you like an Administrator. I've tried a lot of fixes over the months, and I think most manifestations of the problem have been dealt with. But Chrome still won't open normally.

Upon observing Task Manager, I've found that delegate_execute.exe runs for about one second and then goes away.

In addition to creating a new Chrome profile, and reinstalling Chrome, here are some attempted fixes that have not worked:

Fix #1:

Right-click the Chrome icon in the Taskbar
Right-click on 'Google Chrome' in the menu
Left-click 'Properties'
Left-click 'Advanced' under 'General' tab
Check 'Run as administrator', OK, OK

Fix #2:

Right-click the Chrome icon in the Taskbar
Right-click on 'Google Chrome' in the menu
Left-click 'Properties'
Left-click 'Compatibility' tab
Check 'Run as administrator' under 'Privilege level', OK

Fix #3:

Right-click the Chrome icon in the Taskbar
Left-click 'Unpin this program from taskbar'
Start Chrome
Right-click the icon again
Left-click 'Pin this program to taskbar'

Fix #4 (as per http://piglings.blogspot.de/2009/04/google-chrome-not-working-google-chrome.html):

Run cmd
cd C:\Program Files (x86)\Google\Chrome\Application\(version number)\Installer
setup.exe --rename-chrome-exe

Any help would be appreciated.

Windows 8, Version 6.2 (Build 9200)

  • Why do you think it has something to do with a more general problem? Which manifestations did you see? Why are you trying to start a browser as administrator? It's not supposed to run that way. – Tamara Wijsman Jul 24 '13 at 17:45
  • @TomWijsman Windows 8 has a hard time running exe files unless you run them as an Administrator. That's why I thought that this problem was perhaps related. – 76987 Jul 24 '13 at 18:02
  • Does this happen when your running "the explorer" or the system as it would be, elevated, or as admin? Does it do the same thing if you are working as a "user"? – Psycogeek Jul 27 '13 at 10:18

10 Answers 10


Nothing happens.

This is always false, by design; if you make a mouse click, lines of code get executed. Now, you don't get the expected result; what happens at ... in "Click --> ... --> Browser pops up"?


You've clicked; so, the driver catches processes this and together with the kernel and window manager it produces a mouse event which is then processed. You can see this being processed, as the icon lights up at the bottom; the task bar informs there that it has received its mouse event. We can be certain that this part of the executed code works.

Locating and launching the executable...

The icon on the task bar has a location specified in its properties; the executable there is found, properties are checked and then finally it is launched. Well, if everything goes right; it could be that locating goes wrong, but then you would get a warning and it could also be that the properties or launching goes wrong, but then you get a warning as well. So, nothing really goes wrong here, if you can see the process; if it did, you would see this by either a warning or an entry in the event logs.

Google Chrome's turn.

So, the executable is launched; now Google Chrome starts to load all its libraries, all its settings, all data, your user profile and some more. That's really a mouthful; so yeah, a lot can go wrong here. Will it tell you what went wrong? Not always. Will some uneducated fix attempt work? Maybe, unlikely.

Where's my browser window?!

It is there, or maybe it isn't; hard to tell. For all we know, as you described the process is present; because you are able to use its tasks. So, it is either stuck on something or something failed; but what. This is where you need to inspect the situation.

Look at the state of the multiple processes, look at their threads; which functions are they stuck at? If you can't see it from the current state as is, you'll need to look at a trace instead; does it write to some log file? Does it result in ACCESS DENIED trying to access some file? Is a file missing? ...?

Can I or anyone tell what went wrong without such details; no, we can't, you'll need to inspect how things work in order to know why it is broken the way it is.

I just want my browser window!

Sometimes you can't fix something that is horribly broke; you need to start over then, that means by trying to replace things from the bottom up from easy to hard:

  1. Start a new browser profile.
  2. Reinstall the browser.
  3. Start a new user profile.
  4. Restore a backup.
  5. Reinstall your operating system.
  6. Buy a new computer.

Up to you whether you want to troubleshoot and fix it or nuke it and start from scratch.

|improve this answer|||||
  • I am currently downloading the software you have recommended. In the meantime, neither starting a new browser profile nor reinstalling the browser have solved the problem. – 76987 Jul 24 '13 at 18:31
  • I get the following error message when I try to run procexp.exe: "Unable to extract 64-bit image. Run Process Explorer from a writeable directory." The message shows up no matter what directory I run the file from: currently it is in C:\ProcessExplorer\. – 76987 Jul 24 '13 at 18:37
  • Now procexp.exe is working. It had nothing to do with the directory. Windows 8 needed me to run it as an Administrator. But now I am looking at the program, and I don't see Chrome anywhere. Is there some particular place I should be looking? – 76987 Jul 24 '13 at 18:52
  • If chrome.exe does not appear in Task Manager of Windows or in Process Explorer, even when you click on the button to show all processes; then my assumption is wrong, and it would indeed mean the process isn't getting started. So, you could try to capture a trace of when you click the button; to see why chrome closes itself. Feel free to attach the trace to your question; so, others can look into it (I won't be able to the next days). – Tamara Wijsman Jul 24 '13 at 19:48
  • If I observe Task Manager (in the Details tab), I see delegate_execute.exe appear and disappear after one second. Returning to Process Explorer, I see the same thing, except that delegate_execute.exe appears in green and then turns red before disappearing. – 76987 Jul 25 '13 at 4:01

I had exactly the same problem and have come up with two workarounds. I hope this helps others that are having the same problem. I searched all over for a solution but couldn't find one.

The first one is the simplest and gives you some extra apps. The down side is you need two clicks to open chrome. Install Chrome app launcher for Windows.

The second option is to make two files and download one free program. I created this files in my Chrome folder C:\Program Files (x86)\Google\Chrome\Application. Your folder may be different. Use notepad to make and edit both files.

The first is a simple batch file that contains Chrome.exe. So just change the extension from txt to bat and rename it Chrome.

The second file should contain the following VB content:

Set WshShell = CreateObject("WScript.Shell") 
WshShell.Run chr(34) & "C:\Program Files (x86)\Google\Chrome\Application\Chrome.bat" & Chr(34), 0
Set WshShell = Nothing

Now change the name to Chrome and the extension to vbs. You will need to edit the path if your chrome batch file is in a different folder. I only added the second VBS file because it hides the dos box that appears when you run the batch file, if that doesn't bother you then you don't need it.

Windows will not let you pin this file to the taskbar, so I downloaded this simple free program called Pin to 8. Just unzip the file and run the 32bit or 64bit version and pick the file you want to pin to your taskbar. You can pin more than just files, it's a good utility.

The only other thing that I did was to create a shortcut so that I could change the icon to the chrome icon. The shortcut was the file I pinned to the taskbar.

There is probably an easier way to accomplish the same as what I just described above, so if anybody knows a better way please do share. And if anybody knows of the proper solution in stead of these work a rounds I would defiantly love to know.

|improve this answer|||||

I experienced similar problem where I was able to get my chrome back working by restoring my system using an automatic restore point, where it was working fine. Normally system restore takes 5-10 minutes and the programs that installed after restore point will get uninstalled. This really worked for me. You can try this for how to restore system and here are some faqs. Hope your problem gets fixed.

|improve this answer|||||
  • 1
    Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – slhck Sep 9 '13 at 7:55
  • @slhck thanks for suggesting. But my intention was to provide an answer accurately rather me typing some mistakes. – IronMan007 Sep 9 '13 at 8:01

I have had this same problem in win 8 and Win 8.1, the best work around I have found is to browse to the patch release folder, in my case it was :

C:\Program Files (x86)\Google\Chrome\Application\30.0.1599.101
  • Find the chrome_launcher.exe application,
  • Use properties --> compatibility to change settings for all users and check off 'run as administrator',
  • Now create a shortcut to your elevated chrome_launcher.exe in a place that won't get overwritten on the next chrome update
  • Right click your shortcut, choose properties and then 'change icon', browse to the chrome.exe file and swipe the chrome icon. For me, chrome.exe was @: C:\Program Files (x86)\Google\Chrome\Application\
  • Pin your new shortcut to Start / Taskbar and return to a happy one-click to chrome.

Notes: Unfortunately, as it's not actually pointing to chrome.exe you don't get any of the right click options (bookmarks, open incognito, etc).

|improve this answer|||||
  • Note that this might not be optimal as this would give any addons in the browser administrator privileges to, so that if something goes wrong or the addon has malware, then things might go wrong. – Mogget Nov 2 '13 at 11:22

My personal fix for this problem is to: 1. Go to registry editor 2. Delete the Chrome and ChromeHTML folders in HKEY_LOCAL_MACHINE\SOFTWARE\Classes\ 3. Open chrome 4. Set as not default.

Everything will be perfectly fine (including opening URLS in other applications that you want to send to Chrome)... except I have to do this process every restart. Creating a macro for it might be good.

BTW I tried reinstalling Chrome clean several times with Admin rights and it didn't fix. Hopefully someone finds the true source of this error.

|improve this answer|||||

As it is described in this thread, this was fixed for me by deleting the current user and manually removing:

C:\Users\UserName\AppData\Local\Google\Chrome\User Data

Then also check the properties of

C:\Users\UserName\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar\Google Chrome

link. It shouldn't be marked as run as administrator in my case.

|improve this answer|||||

I found the simplest solution is to make sure you have the shortcut on the desktop. Right click the desktop shortcut and pin to taskbar. The taskbar shortcut should open browser window when clicked. If you do not want to see desktop shortcut, right-click, choose properties, then select the general tab, click the "hidden" checkbox and it will not appear on desktop.

|improve this answer|||||

I know how to fix this, as I just fixed it myself, the cause is chrome.exe being set to always run as admin via the properties>compatibility tab (we don't want this for many reasons).

To FIX THIS, JUST right click the chrome icon in taskbar, then right click the google chrome line (again), then click properties, then go to compatibility, then uncheck run as admin box, if its grayed out u need to click the "change for all users" button and uncheck it in there.

^ or browse to the programfiles/chrome/exes and make sure u uncheck run as admin for all of them, this goes for any startup applications u want as well, because anything run as admin all the time will fail to start via exe/startups.

|improve this answer|||||

I was able to fix this issue by opening task manager and ending any background Google chrome processes. hope this helps

|improve this answer|||||

This really worked! I know how to fix this, as I just fixed it myself, the cause is chrome.exe being set to always run as admin via the properties>compatibility tab (we don't want this for many reasons).

To FIX THIS, JUST right click the chrome icon in taskbar, then right click the google chrome line (again), then click properties, then go to compatibility, then uncheck run as admin box, if its grayed out u need to click the "change for all users" button and uncheck it in there.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.