2

I'm trying to delete files on Windows 8 and I get the following error message:

Delete screenshot

Which translates to "Invalid MS-DOS function". If I try to SHIFT+DEL a file to skip the Recycle Bin it looks like the file is deleted but after a few seconds it reappears.

Does anyone know how to solve this?

2
  • Can you delete them in safe mode? – Raystafarian Jul 23 '13 at 10:30
  • Yes, it was as easy as that. And after booting back to normal mode everything was ok. Can you make it as an answer? (briefly explaining how to boot into safe mode) – HenryHey Jul 24 '13 at 6:43
3

Try to see if you can delete them without errors by booting into safe mode.

One way to boot into safe mode is to

  1. Press Windows + R
  2. Type msconfig
  3. Go to the boot tab and select safe boot
  4. Select any other options and press OK and restart the computer

If you can delete them there and restart back into normal mode, the problem may be fixed. If not, additional troubleshooting may be required.

Some possible causes of the issue may be that the hardware is failing or the OS cannot map properly to the hardware. If you have other drives, or perhaps a USB drive, check for the same error.

Unfortunately, I can't find any resources that may identify the root cause.

0

I wasn't able to remove the file using Windows, but I was able to connect the removable drive to a Linux VM and delete it from there.

I didn't try from a Cygwin or other window/bash prompt, but that might have worked too.

1
  • I did try Cygwin and it didn't work (rm wouldn't complain but the file would still be there), I needed to go for booting in safe mode. – user2891462 Mar 17 '16 at 11:35

Not the answer you're looking for? Browse other questions tagged or ask your own question.