10

DNS in chrome is not using my VPN DNS:

  1. Things that should match private vpn DNS records are instead resolving again a public wildcard address
  2. This only seems to happen in Chrome, iterm pings and firefox resolve correctly
  3. clearing the host cache via chrome://net-internals/#dns doesn't help, not does clear all cache via settings. Restarting Chrome also doesn't seem to help
  4. Going to a website via IP in Chrome works fine
7

For some reason using the "Built-in Asynchronous DNS" was not selecting my VPN DNS servers. I could see that the VPN DNS server was not being used via chrome://net-internals/#dns. As a workaround, I disabled this via chrome://flags:

enter image description here

0

Try disabling Async DNS Resolver. In Chrome for Android, go to chrome://flags. Search for "Async DNS Resolver", and disable it.

  • @bertieb Thanks for bringing this to my attention. – backtabber Sep 21 '18 at 15:57
  • I don't see that flag in chrome://flags, can it still be disabled? – foucdeg Mar 15 at 10:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.