I have a Lenovo Z585 Ideapad which I put into hibernate frequently. When I do it manually, the machine hibernates and resumes successfully. However, if I close the lid, which I have set to Hibernate instead of Sleep, the machine fails to resume from hibernate about 30% of the time and restarts with

Windows failed to resume from hibernate with error status 0xC0000001


The system has rebooted without cleanly shutting down first. This error could be caused if the system stopped responding, crashed, or lost power unexpectedly.

Why does closing the lid cause different behavior?

In case it's unclear, I'm closing the lid which causes it to hibernate 100% of the time, but the computer fails to resume ~30% of the time.

  • Sounds like closing the lid is somehow forcing the laptop to power down, even though it's mid-hibernation. The times it works might be when it's done hibernating just in time for the power down. Are there any power options in the BIOS you can tweak? – trpt4him Jul 23 '13 at 16:53
  • @Matthew - What operation do you currently have set when the lid is closed? – Ramhound Jul 23 '13 at 16:59
  • Do you have any minidumps to narrow down the culprit? Use Bluescreenview for viewing of any minidumps. Bluescreenview will allow you to see if you have any minidumps (which typically occur when a computer bluescreens or crashes) and to get the bugcheck code/string and driver/program that is caused the computer to fail going into hibernation. Here is a reference screenshot to show what you need to look for in the program. Screenshot (I'm not at a high enough level to post screenshots direct – kmg90 Jul 23 '13 at 17:28
  • @Ramhound I simply have it set to hibernate when lid is closed for every state (plugged in, on battery, power-saver, high performance, etc). – Matthew Jul 23 '13 at 17:43
  • @kmg90 I tried doing everything here which indicated a hal.dll (Hardware Abstraction Layer) error which doesn't help that much. After running "dism /online /cleanup-image /restorehealth" and "sfc /scannow", it seemed to be working correctly... until I just got another crash today. I'll see if I can get some help from the Microsoft website. – Matthew Jul 31 '13 at 17:11

Hibernation can fail if the hibernatin file (hiberfile.sys) is too small. By default Windows will use 75% of the RAM size. Maybe this is not enough. Use powercfg to set the size to 100%. Open a command prompt with adminrights and run this command:

powercfg -h -size 100

In Windows 8 I had to do this.

powercfg /h /size 100

Now check if Hibernation/resume works fine.

  • I set the hiberfil.sys size to 100% beforehand. Plus, that wouldn't explain why opening the lid fixes the problem. Thanks though. – Matthew Jul 25 '13 at 1:20

Try updating your drivers (manually, or using DriverMax).

If that doesn't work, try this article: Fix: Error Code 0xc0000001 in Windows 8 After Updating Windows

  • Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – slhck Jul 23 '13 at 19:18
  • @Luke I've done both of those and neither solution worked for me. I probably should've stated that somewhere. – Matthew Jul 23 '13 at 21:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.