I got an ISO of Windows XP Professional with SP3 integrated from dreamspark. I burned it onto a DVD, and installed onto an old computer of mine.

The first thing I did after installation was install the graphics drivers as I can't stand the extreme lag when I drag windows around. Then I scanned for updates in IE, but it hung for a while. I checked Task Manager, and found out that one of the svchost's was hogging the CPU.

Later, I used SysInternals Process Explorer to check the services associated with that instance of svchost. There was a list, but Automatic Updates was one of them. I stopped that service, and CPU went down instantly. I tried reinstalling as well (twice...), but the same results are produced every time. This hasn't happened before, ever...

I tried installing Windows Update Agent using the /wuforce parameter, rebooted, and nothing...

I also tried installing this hotfix, but apparently SP3 already took care of that...

I also read somewhere that this is caused by SP3 not installing properly. So I tried downloading the ISO for XP that doesn't have any SPs integrated, but I wasn't allowed because I already have a copy of XP in DreamSpark, and it does not let me add the one without SPs to the cart. This is as far as I went


  • AMD Sempron 3200+ 1.8GHz
  • 3GB DDR2 RAM (2 Sticks of 1GB, and 2 sticks of 512MB)
  • Nvidia GeForce 6100
  • Seagate 500GB SATA

What do I have to to fix the svchost problem?


I checked WindowsUpdate.txt log, and these are some of the entries:

DownloadFileInternal failed for http://download.windowsupdate.com/msdownload/update/v5/redir/wuredir.cab: error 0x80190194
Failed to download the Redirector cab on try 1: 0x80190194

WU client failed Searching for update with error 0x8024001b
Required Version for binary C:\WINDOWS\system32\cdm.dll is: 7,6,7600,256
Binary: C:\WINDOWS\system32\cdm.dll: Target version: 5.5.3790.5512 Required: 7.6.7600.256
Required Version for binary C:\WINDOWS\system32\wuapi.dll is: 7,6,7600,256
Binary: C:\WINDOWS\system32\wuapi.dll: Target version: 5.4.3790.5512 Required: 7.6.7600.256
Required Version for binary C:\WINDOWS\system32\wuauclt.exe is: 7,6,7600,256
Binary: C:\WINDOWS\system32\wuauclt.exe: Target version: 5.4.3790.5512 Required: 7.6.7600.256
Required Version for binary C:\WINDOWS\system32\wuaucpl.cpl is: 7,6,7600,256
Binary: C:\WINDOWS\system32\wuaucpl.cpl: Target version: 5.4.3790.5512 Required: 7.6.7600.256
Required Version for binary C:\WINDOWS\system32\wuaueng.dll is: 7,6,7600,256
Binary: C:\WINDOWS\system32\wuaueng.dll: Target version: 5.4.3790.5512 Required: 7.6.7600.256
Required Version for binary C:\WINDOWS\system32\wucltui.dll is: 7,6,7600,256
Binary: C:\WINDOWS\system32\wucltui.dll: Target version: 5.4.3790.5512 Required: 7.6.7600.256
Required Version for binary C:\WINDOWS\system32\wups.dll is: 7,6,7600,256
Binary: C:\WINDOWS\system32\wups.dll: Target version: 5.4.3790.5512 Required: 7.6.7600.256
Required Version for binary C:\WINDOWS\system32\wups2.dll is: 7,6,7600,256
Binary: C:\WINDOWS\system32\wups2.dll: Target version: Required: 7.6.7600.256
Required Version for binary C:\WINDOWS\system32\wuweb.dll is: 7,6,7600,256
Binary: C:\WINDOWS\system32\wuweb.dll: Target version: 5.4.3790.5512 Required: 7.6.7600.256
Required Version for binary C:\WINDOWS\system32\wuapi.dll.mui_en is: 7,6,7600,256
Binary: C:\WINDOWS\system32\wuapi.dll.mui_en: Target version: Required: 7.6.7600.256
Required Version for binary C:\WINDOWS\system32\wuaucpl.cpl.mui_en is: 7,6,7600,256
Binary: C:\WINDOWS\system32\wuaucpl.cpl.mui_en: Target version: Required: 7.6.7600.256
Required Version for binary C:\WINDOWS\system32\wuaueng.dll.mui_en is: 7,6,7600,256
Binary: C:\WINDOWS\system32\wuaueng.dll.mui_en: Target version: Required: 7.6.7600.256
Required Version for binary C:\WINDOWS\system32\wucltui.dll.mui_en,SusClient_wuauhelp,SusClient_wuauadm is: 7,6,7600,256
Binary: C:\WINDOWS\system32\wucltui.dll.mui_en,SusClient_wuauhelp,SusClient_wuauadm: Target version: Required: 7.6.7600.256

WU client failed Searching for update with error 0x8024001b

Failed to obtain cached cookie with hr = 8024400a.
PT: Using serverID {9482F4B4-E343-43B6-B170-9A65BC822C77}
PT: Using server URL https://www.update.microsoft.com/ClientWebService/client.asmx
URL for server  is http://stats.update.microsoft.com/ReportingWebService/ReportingWebService.asmx

WUAUENG ServiceMain exits. Exit code is 0x240002

// this is when I installed the 1 mandatory update automatically detected...
# 127 updates detected
# Found 1 mandatory updates


I gave up and installed Windows 7 Professional without Service Packs. svchost ate up CPU again, but only for a minute, and then Windows Update showed about 150 updates I'm missing. Something's wrong with Windows XP and I don't know what... Windows 7 works better so I guess I'll just stick with this then...

  • I'd recommend just letting it go overnight, more than likely it's downloading and installing a bunch of hotfixes, new version of IE, Security Essentials, etc. With your processor, that could take up a lot of the resources, but if you let it finish, then you should be good. – Taegost Jul 24 '13 at 17:16
  • @Taegost But that's never happened before. I had Server 2003 before this, and all initial updates were found in about a minute, and nothing hung – Alex Jul 24 '13 at 17:18
  • Did you have Server 2003 installed on that specific computer before? It could really be anything, and the only way to find out is to start eliminating causes... If you've verified that the Automatic Updates service is causing the high usage, let it complete it's job and see if it returns to idle, especially since you're running on a very outdated single-core CPU. – Taegost Jul 24 '13 at 18:27
  • @Taegost Yes, on the exact same computer, with the exact same hardware configuration. I've also had Server 2008 R2 as well, and I never had this kind of difficulty with initial updates – Alex Jul 24 '13 at 20:11
  • Anything in the logs? (e.g in c:/windows/WindowsUpdate.log). Does it help it you run a net stop wuauserv, then delete the softwareDistribution folder, net start wuauserv and runwindows updates? – Hennes Jul 24 '13 at 21:01

Manually downloading and installing Internet Explorer 8 solves the issue.

Confirmed on two types of systems:

  1. Old install of Windows XP Professional SP3 (manufacturer recovery CD) on a Intel PC, having Internet Explorer 6 for legacy software comparability. The other systems that have been updated to Internet Explorer 8 do not experience the issue.
  2. New install of Windows XP Home SP3 (manufacturer recovery CD) on a AMD netbook.

So, the issue appears only if Internet Explorer 6 is present. First time it happened is between March and May this year (do not remember exactly). Updates coming with Internet Explorer 8 solve that issue.

| improve this answer | |
  • This worked for me. In my opinion, MS shouldn't of made Windows/Microsoft Update so attached to IE. It should've been a dedicated service/application like in Vista+.. anyways, thanks for the info and it makes sense this was the problem now. – ScottN Sep 30 '13 at 2:07
  • To add to your estimate on when this started, I did a re-install of XP with SP3 on an older laptop in early June and didn't have an issue with Windows Update and IE6. – ScottN Sep 30 '13 at 2:12
  • Confirmed; I installed XP SP2 from CD, applied SP3 from another CD, plus IE8 which I downloaded a few months ago. A fresh download of IE8 from microsoft.com reinstalled exactly the same version (8.0.6001.18702), but now the update process continues. First two small upgrades (WGA + 1 other), followed by the rest. Reinstall of IE8 does takes a long time, though. – JvO Oct 15 '13 at 3:30

I gave up and installed Windows 7 Professional x86_64. svchost ate up the CPU when I checked for updates, but updates were found a minute later, so everything's good now. Something must be wrong with Microsoft's Windows XP ISOs on DreamSpark

| improve this answer | |

I ran across the same issues and narrowed down a list of prerequisites that worked for me (on freshly installed Win XP SP3 systems).

First: After a clean install, Windows update won't work. It first needs Windows Update Agent 3.0 (a.k.a. 7.4.7600.226) per KB946928. Note this page crashes the SP3's IE 6. The link to download the EXE per the KB is: http://download.windowsupdate.com/WindowsUpdate/redist/standalone/7.4.7600.226/WindowsUpdateAgent30-x86.exe

Second: After this, Windows Update should work (at least the "Custom" option, I didn't test the "Express" option), but you may run into the 100% CPU with svchost issue while it searches for updates. Installing "Cumulative Security Update for Internet Explorer for Windows XP (KB2870699)" fixed this issue for me: http://www.microsoft.com/en-us/download/details.aspx?id=40069 (x86 download) (NOTE: I had IE 6 installed at the time. Per the KB, this update will work for IE 8 too if it's already installed. However, I did not have this tested.)

Finally, during the update, your system WILL hang at 100% CPU on svchost for an hour or two when "Windows Genuine Advantage Notification (KB905474)" is installing. You could either wait for it to finish (and it will, I've tried on three new system installs in the last few days), or do not select that update.

After these humps, I was able to install all other High Priority and Optional updates manually without further issues. Lastly, note that contrary to some forums I've read, I was able to get this working under IE 6. IE 8 was NOT a prerequisite for me (at least on 10/1/2013). Though after all the High Priority updates, IE 8 was upgraded for me.

| improve this answer | |

I still keep Internet Explorer 6 in my Windows XP and I’ve had the 100% CPU issue in svchost.exe / wuaueng.dll. This only happened every second tuesday of these last two months, that is, Patch Tuesday. I managed to work it around in October, but last Tuesday I had same problem again.

Since I refused to update to IE8 and I read that there is some correlation between these two facts, I tried to manually download and install KB2888505 (Cumulative security update for Internet Explorer: November 12, 2013). It installed fine and after that, Windows Update detected, downloaded and installed remaining updates without any CPU hog. I guess that as long as I keep IE6 I’ll have to manually download and install its security patches from now on.

So, the key here is IE6; the easy solution is to upgrade to IE8; the workaround is to manually install its security updates when Windows Update Agent gets stuck using 100% CPU.

| improve this answer | |
  • December, same story. Manually download and install KB2898785. – Chungalin Dec 11 '13 at 10:42

Svchost CPU hog (100%) : got into this problem too. Here is what I tried and what worked. tried on my Windows XP Home SP3:

  • download WinUpdate agent 3.0 from microsoft, installed with "/wuforce", rebooted -->fail
  • re-applied SP3 to no avail : the hog is still there
  • used also MS Fixit for Win Update for XP --> Nothing better
  • tried complementary IE8 update (KB2870699) --> fail again
  • used the usual trick
  • (net stop wuauserv, delete %Windir%\SoftwareDistribution, net start wuauserv) --> still fail : WUpdate opens and seeks forever, CPU hog again).

Finally I managed to download an IE8 install program (found mine on Clubic but should exist at MS for your particular language). This one uninstalled fully my current IE8 and installed a fresh one on reboot ==>DONE ! It is a long install and you need to tweak IE again, but it was worth it ! I am currently writing this while MS Update does its job (25+ updates ...).

I have to point that :

  • IE6 and Updates did not work well on my machine on a fresh install.
  • I had to download and install IE8 + WindowsUpdate agent 3.0 first.

  • My current problem of CPU hog was indeed an IE8 deep and hidden problem (probably after some kind of MS update or something else).

  • Never forget that IE, desktop/taskbar behaviour and WinUpdate are tightly linked.

I learned a lot in this thead, so I give back now.

| improve this answer | |

Running XP Pro 32Bit new install on a Dell Latitude D800. I had the same problem with Genuine Windows Update KB905474 freezing and using 100% CPU. I updated IE to IE8 but the update would still feeze and use 100% CPU. I shut off Automatic Updates and then used the Windows Update link and the custom install to install all updates except for KB905474. I then downloaded and saved the KB905474 update to my desktop. I shut down then rebooted into Safe Mode With Networking. I ran the KB905474 update in this mode and it installed with no issues. Shut down again rebooted back up on Normal Mode and turned Automatic Updates back on. The computer is run ning fine with no issues. This worked for me with the KB905474 update hopefully it will help you.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.