6

I used a CloneZilla LiveCD to back up a couple of Windows machines to a Samba share. Now I'm trying to restore those images, and CloneZilla won't even give me the 'restoredisk' or 'restorepart' options on the menu. I'm guessing that this is because CZ isn't recognizing a valid image... but why?

Here's a listing of the folder on the Samba share:

-rwxrwxrwx 1 marc users        319 May 31 03:45 blkdev.list
-rwxrwxrwx 1 marc users       5307 May 31 04:41 clonezilla-img
-rwxrwxrwx 1 marc users          4 May 31 04:31 disk
-rwxrwxrwx 1 marc users      16091 May 31 04:31 Info-dmi.txt
-rwxrwxrwx 1 marc users      11029 May 31 04:31 Info-lshw.txt
-rwxrwxrwx 1 marc users       1502 May 31 04:31 Info-lspci.txt
-rwxrwxrwx 1 marc users        170 May 31 04:31 Info-packages.txt
-rwxrwxrwx 1 marc users         80 May 31 04:41 Info-saved-by-cmd.txt
-rwxrwxrwx 1 marc users         10 May 31 04:31 parts
-rwxrwxrwx 1 marc users 2097152000 May 31 04:06 sda1.ntfs-ptcl-img.gz.aa
-rwxrwxrwx 1 marc users  247361656 May 31 04:08 sda1.ntfs-ptcl-img.gz.ab
-rwxrwxrwx 1 marc users  823182034 May 31 04:31 sda2.ntfs-ptcl-img.gz.aa
-rwxrwxrwx 1 marc users         36 May 31 03:45 sda-chs.sf
-rwxrwxrwx 1 marc users      31744 May 31 03:45 sda-hidden-data-after-mbr
-rwxrwxrwx 1 marc users        512 May 31 03:45 sda-mbr
-rwxrwxrwx 1 marc users        315 May 31 03:45 sda-pt.parted
-rwxrwxrwx 1 marc users        285 May 31 03:45 sda-pt.parted.compact
-rwxrwxrwx 1 marc users        259 May 31 03:45 sda-pt.sf

(I've been experimenting with various permissions trying to get this to work; that's why they're currently all "rwxrwxrwx"...)

I've got my CZ LiveCD stuck in a (different) machine with a 160GB SATA disk that I'm fine with overwriting; although CZ doesn't show a directory listing, it does show that the correct folder is mounted as /home/partimag. But a moment later, after selecting either Beginner or Expert, I'm only presented with the "savedisk", "saveparts", and "exit" options. What am I doing wrong?

I am confident that the initial backup was successful; I can post the log if desired, or any other information that might be germane.

Edit: I've copied the contents of the folder onto a 16GB USB stick and set THAT as /home/partimag. Still nothing. What the hell is CZ looking for?

8

I think I've figured it out - for local_dev, anyway; tomorrow I'll find out whether this applies to Samba as well. I suspect it does. (Edit: YES!)

When I backed up the Windows machines to Samba, it created a folder for each image. When I tried to restore one of those images, I specified that subfolder to be mounted as /home/partimag; apparently this was my mistake. When I copied the files onto a USB stick, I copied them to the root folder - and, as I mentioned above, it still didn't see anything to restore.

Out of some sort of inspiration/desperation, I created a subfolder on the USB stick, moved the files into it, and tried again - and lo and behold, I have now restored that image successfully! Tomorrow I'll try telling CZ to mount the root of the Samba share as /home/partimag, and I suspect I'll be given a choice of images to restore. (I'll update this answer according to my findings.)

Bottom line: CloneZilla has a blind spot in the root folder of whatever you specify as /home/partimag. You've got to tell it to look (at least? needs testing) one level above the folder containing your image files. This may be spelled out in the documentation somewhere - but I sure didn't see it, and I wish I had.

2
  • 1
    A quick comment on this (your answer was definitely helpful), but I think I may have found another bug(?). It seems Clonezilla doesn't like it if you duplicate a disk image in the same directory. For example, say you make an image named 2013-10-24-13-img (this is put in a folder named "2013-10-24-13-img/" ). Then, you make a copy of the image folder: /home/partimag$ cp 2013-10-24-13-img 2013-10-24-13-img-copy. I'm not certain, but I think Clonezilla was ignoring the entire partimag folder because I had the duplicate in the same directory. Moved the copy, problem solved.
    – blong
    Oct 25 '13 at 15:21
  • 3
    FWIW: This solution also applies to restoring from an image via ssh. Thanks! Apr 10 '14 at 19:56
1

In my case the problem had a different cause - and so required a different solution. I'll leave it here in case it helps someone else -

Clonezilla wasn't recognizing the saved image because it couldn't find some particular files in the directory: disk and parts.

When I had copied the files there, I had used copy-item *.* on Powershell, and it seems this copies only files with extensions... not every file as I thought. The two files mentioned above were thus missing, along with a few others. After completing the copy, Clonezilla was able to recognize that directory as a saved disk image.

So - make sure your image directory contains a complete Clonezilla image.

1

For those people commenting on the chosen solution as provided by MT_head, I was able to analyze my restore image by specifying the parent folder containing the backup folder created by clonezilla originally. My original clonezilla backup job was copied to a samba share. Restoring is possible from any share as long as you DO NOT include the backup folder name in the share path, which in my case was 2015-01-24-20-img/. After specify the correct path, I could see the restore options and image restore test.

0

I have always kept my backups under a /backups directory directly under the root of my archive disk. Since I rarely restore, I'm not sure if this is uniformly the case, but I could not get the restore option to appear until I copied my target restore image file up to the root of my archive disk.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.