18

After upgrading to virtualbox 4.2.16 all of my VMs get stuck at launch.

I tried downgrading to 4.1.26, but I still get the same problem.

Screenshots: [window 1]() [window 2] (not enough rep to post images)

When I kill the stuck process I get the error "no error info"

Result Code: 
NS_ERROR_CALL_FAILED (0x800706BE)
Component: 
ProgressProxy
Interface: 
IProgress {c20238e4-3221-4d3f-8891-81ce92d9f913}

I've been trying to find the global settings for virtualbox to clear them and do another reinstall, but I've only found VM-specific settings.

The system it's running on is xubuntu 12.10. I tried one of the VMs on another computer and there was no issues, so I guess it has something to do with the actual virtualbox installation/config.

5
  • 1
    I upgraded ubuntu and it fixed itself. I guess it was some kind of kernel incompatibility.
    – flote
    Jul 25, 2013 at 19:59
  • flote Feel free to post your solution as an answer, since what you did was a fix!
    – MrDaniel
    Mar 29, 2014 at 13:03
  • IF you have any access to your old settings files for virtualbox, you should make sure you compare them to make sure your settings are the same, i had this problem when going from 12.10 to 13.04, and then 13.10, without missing a beat, turned out some items got changed somehow in the configuration which must have happened during the upgrade, the OS would not start until I restored some of my old settings. May 5, 2014 at 10:45
  • 1
    Since this is the top hit on Google for "virtualbox starting virtual machine hang", I figure it might be helpful to add that when I ran into this, I fixed it by disabling audio. (I don't know what exactly changed, but there must have been a conflict of sorts.) Aug 28, 2015 at 18:05
  • 1
    @The Sidhekin Thanks for that, similar problem here - I had a webcam unplugged when I was using the VM. I plugged in the webcam and the VM would no longer start up, it hung on the startup. Unplugging the webcam fixed the issue. Jan 17, 2017 at 17:00

7 Answers 7

11

In the system option you need to check the "use I/O APIC"

if you were using SATA interface as your storage, you need to check the "Use host I/O cache" option

3
  • Thank you. This I have tried upgrading, downgrading VBox and kernel and nothing worket. This answer is the only that makes any difference.
    – zidarsk8
    Nov 2, 2014 at 9:20
  • Where is this option?
    – Richard
    Aug 19, 2016 at 19:36
  • Ah, here we are: Right click on VM -> Settings -> System
    – Richard
    Aug 19, 2016 at 19:45
2

I had the same problem with VB 4.3.20 under Ubuntu 14.04.1 amd64. The VM images are on a BTRFS disk.

I resolved the problem by turning of the COW for the VM images and snapshot files.

You can turn off the copy-on-write feature of btrfs for single files by setting the NOCOW attribute. This usually done by running chattr +C filename. This only works on empty files, so you have to create an empty file, set NOCOW, copy the contents of the actuale file into the empty file, and rename. (see https://btrfs.wiki.kernel.org/index.php/FAQ#Can_copy-on-write_be_turned_off_for_data_blocks.3F)

There is also a VB bug report (https://www.virtualbox.org/ticket/11862) saying

On a linux machine with btrfs filesystem, installation of a guest goes just fine but at first restart the guest freezes with popup showing "20%" during launch phase. [...] I did some digging on the btrfs wiki and discovered that Copy-On-Write (COW) causes this pain for any virtualization solution.

To set the NOCOW flag, do

F=vmimage
T=tmpfile
touch $T
chattr +C $T
dd if=$F of=$T bs=1M
rm $F
mv $T $F

Use lsattr to check if C was set.

3
  • Please post more info here rather than use links which may go stale - thanks.
    – suspectus
    Jan 15, 2015 at 13:06
  • Also disable COW on your snapshots if you're using them.
    – remvee
    Jan 18, 2017 at 8:59
  • only using the chattr command on the empty vdi does not suffice in my case. I have not tried yet with the full script. Oct 1, 2018 at 21:06
0

I had such behavior. What helped is Exporting the machines to appliance and importing it back.

0

As previously mentioned in my comment, I upgraded ubuntu and it fixed itself. I guess it was some kind of kernel incompatibility.

0

I get this same general error ("No error info." with "Component: ProgressProxy") with VirtualBox 4.2.12 on Windows when I try to launch a virtual machine while the directory that its VDI disk image file is configured to be in is missing.

0

I spent many hours with the same problem.

I found the solution here: https://forums.virtualbox.org/viewtopic.php?f=6&t=63556&start=90

I simply installed the version 4.3.17 (still in dev version) and everything is working perfectly again.

Download here: https://www.virtualbox.org/download/testcase/VirtualBox-4.3.17-96101-Win.exe

0

Didn't work for me too. Host Windows, VM Ubuntu. I got it back running by switching off the sound in the settings of the current VM.

Not the answer you're looking for? Browse other questions tagged or ask your own question.