1

The icons on the system tray usually display a text message when you hover the mouse over them. But that has stopped working in my system some days ago. Is there any Windows setting related to this or is it just a bug (or feature)?

Hovering over the taskbar application icons works, and also with the system clock.

  • 1
    Have you restarted the computer since the problem began? – James P Jul 25 '13 at 13:15
  • Restarting fixed it but it comes back a while after. Seems to be a bug – golimar Jul 25 '13 at 15:40
  • Have you installed any new software or updated any drivers lately? This could include Windows updates. – James P Jul 25 '13 at 16:01
  • Yes, Windows updates – golimar Jul 26 '13 at 10:04
  • It could be worth checking exactly what updates were installed. – James P Jul 26 '13 at 10:08
1

Your tooltips may be disabled.

Try opening regedit as an administrator (press the windows key, type regedit, hit enter) and then navigate to:

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]

Find the "ShowInfoTip" key, right-click it and select "Modify" then change the value to "1"

  • @ golimar did it fix the problem you were experiencing? Or do you mean it was already set to 1? – Jason Bristol Jul 25 '13 at 13:09
  • It was already set to 1 – golimar Jul 25 '13 at 15:41
  • Hmm, I am starting to suspect something else is at fault. You mentioned in comments that a restart fixed it for a little while. I would suggest fixing any registry errors you may have using a tool like CCleaner or similar. – Jason Bristol Jul 25 '13 at 16:08
1

The tooltips might be appearing under (below) the taskbar. This "sometimes happens", probably some bug in Windows. (see this screenshot for an example) When this happens you can see the top of some of the tooltips just above the taskbar (especially if it is a bigger tooltip).

In that case it might help to change some options of the taskbar (right click an empty space on taskbar, then select Properties):

  • in XP there was an option named "Keep the taskbar on top of other windows". Switching it on then off helped. Sadly this option was removed in Windows 7, but it might still be possible to do it some way, see this discussion over at microsoft
  • "auto-hide the taskbar": try turning it on/off
  • try moving the taskbar (unlock it first if needed) to some other part of the screen (it can be on every edge of the screen: left, top, right, and as usual: bottom)
1

Tray icon tooltips stop showing on my Windows 7 relatively often. Less often lately, but today it happened again. Restart the explorer.exe process that is responsible for showing the tray to fix the problem. For instance, "kill" it with the Task Manager and then "run" "explorer.exe" from the Task Manager's menu.

Note that there might be several instances of the explorer.exeprocess running on your system. Only one of them is responsible for drawing the tray (, taskbar, and desktop). The other(s) are usually responsible for the file system browsing "Explorer" windows.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.