0

I've disabled dead keys on my Swedish keyboard layout to more easily type characters such as ~,´ and `.

How do I temporarily enable the old behavior of these keys? Now I can't type an e with an acute character, for instance. Do I need to switch keyboard layouts temporarily, or is there some key-combo I am missing out on?

2

You can press Ctrl+Shift+U, then hold down Ctrl+Shift while typing the Unicode code point of any character, then release Ctrl+Shift to realize it as a character. For example, to type é, this becomes Ctrl+Shift+U+E9 because é is U+00E9 (you don't have to type out the initial zeroes).

This trick works fine with GTK-based applications running under Xfce for me.

If you only need to type a few different such characters, this may be acceptable, but I'll be the first to admit that I wouldn't want to commit half of even the Unicode BMP to memory.

Another alternative is to augment the key map to define a Compose key, as suggested by ott-- in the comments. I looked around a little and couldn't immediately find any way to do it through the GUI (from the looks of the Wikipedia article it should be perfectly doable, but I failed to find the dialog in question), but did come across a forum post that suggested using the likes of setxkbmap -option compose:rwin, which could quite possibly be done through ~/.xinitrc or ~/.xsession. Then Compose+' followed by E (where Compose = Right Win) yields É.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.