2

Problem: When deleting a symbolic link, traces of it remain in the filesystem.

Demonstration:

  • Use MKLINK to create a symlink pointing to E:\test MKLINK
  • Resulting output of DIR /AL /S C:\ | FIND "SYMLINKD": DIR output
  • Delete symlink (I just deleted the folder/shortcut in AppData using Windows Explorer)
  • Output of DIR /AL /S C:\ | FIND "SYMLINKD" after deleting symlink: Resulting DIR output after deleting symlink

I expected the entry to be completely gone. Instead it is still there, only instead of the folder name, there is an identifier that I don't recognize.

I originally noticed something strange when I uninstalled the game Age of Empires Online, and noticed that the folder on the target drive was still there with all its data. So, I ran the DIR command to see if I the symlink was still active, it was. I thought it unusual but paid it no mind, and deleted the symlink as I normally would. I ran the command again, and it was still there with a similar identifier to that seen in the demo.

I am running Windows 8.1 Preview and noticed it has a new kernel, 6.3. I wondered if it was something new with NTFS, but have been unable to find anything.

Is there a way to completely remove it?

0

It turns out that the folders were in my Recycling Bin, and were renamed to that $XXXXXXX format. Emptying the bin got rid of them.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.