2

I'm unable to get any applets to work in any browser.

I am 99% sure that this error happened after updating Java 7 runtime to update 25 (on OSX Mountain Lion).

Some more detail on my problem: this is occurring on every browser I use (tested on Firefox, Safari and Chrome). I am a home user. Applets used to work before, until I updated to jre7 udpate 25.

The applet does not load. Instead there is a red error message reading "Error. Click for details". When I click on this I don't get many details, simply the Java console with this bit of useful info about the version:

Java Plug-in 10.25.2.15 Using JRE version 1.7.0_25-b15 Java HotSpot(TM) 64-Bit Server VM

Other things I have tried: - reinstalling Firefox - deleting and reinstalling JRE 7 update 25 - run the java tester at javatester.org: same red error text

I don't see rolling back to a lower version of the java plugin to be a long-term solution. I really think this is because of either Apple or Oracle who have broken something or some security feature is causing older applets to not be allowed to run.

Have now reached the limit of my own troubleshooting skills. Hope someone can provide a good solution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.