0

Can anyone advise on how to resolve this?

Cannot complete the install because of a conflicting dependency.   Software being installed: Eclipse Git Team Provider
3.0.1.201307141637-r (org.eclipse.egit.feature.group 3.0.1.201307141637-r)   Software currently installed: EGit Plug-in Import Support 2.3.1.201302201838-r (org.eclipse.egit.import.feature.group 2.3.1.201302201838-r)   Only one of the following can be installed at once: 
    Git Team Provider UI 2.0.0.201206130900-r (org.eclipse.egit.ui 2.0.0.201206130900-r)
    Git Team Provider UI 2.2.0.201212191850-r (org.eclipse.egit.ui 2.2.0.201212191850-r)
    Git Team Provider UI 2.3.1.201302201838-r (org.eclipse.egit.ui 2.3.1.201302201838-r)
    Git Team Provider UI 2.1.0.201209190230-r (org.eclipse.egit.ui 2.1.0.201209190230-r)
    Git Team Provider UI 3.0.1.201307141637-r (org.eclipse.egit.ui 3.0.1.201307141637-r)   Cannot satisfy dependency:
    From: Eclipse Git Team Provider 3.0.1.201307141637-r (org.eclipse.egit.feature.group 3.0.1.201307141637-r)
    To: org.eclipse.egit.ui [3.0.1.201307141637-r]   Cannot satisfy dependency:
    From: EGit Plug-in Import 2.3.1.201302201838-r (org.eclipse.egit.import 2.3.1.201302201838-r)
    To: package org.eclipse.egit.ui [2.3.1,2.4.0)   Cannot satisfy dependency:
    From: EGit Plug-in Import Support 2.3.1.201302201838-r (org.eclipse.egit.import.feature.group 2.3.1.201302201838-r)
    To: org.eclipse.egit.import [2.3.1.201302201838-r]

I have been able to narrow down the update list to the following. If any of the following are selected I get the message above.

Command Line Interface for Java implementation of Git   3.0.0.201306101825-r
Eclipse Git Team Provider   3.0.1.201307141637-r
Java implementation of Git  3.0.0.201306101825-r
Task focused interface for Eclipse Git Team Provider    3.0.1.201307141637-r

This is a genuine and perfectly legitimate question regarding a very specific situation I find myself in. Please don't down vote without leaving a comment

1 Answer 1

2

After much headache (and massive disappointment with the superuser community here) I managed to solve my problem by uninstalling all the git components

Command Line Interface for Java implementation of Git   3.0.0.201306101825-r
Eclipse Git Team Provider   3.0.1.201307141637-r
Java implementation of Git  3.0.0.201306101825-r
Task focused interface for Eclipse Git Team Provider    3.0.1.201307141637-r

Then tried to add the egit plugin again. When I attempted to install I got the message that it was already installed (which left me with the impression that the Eclipse uninstall procedure is broken as nothing was showing in my list) and would perform an update instead.

After the update was performed I have eGit installed and up to date.

The whole process seems very strangely wrong but the job is done and documented here for any other victims needing an answer.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .