I found that Windows 8 Task manager does not show network usage correctly:


As you see, my torrent client downloads at a speed of 1 MB/s, while Windows shows zero.

All adapters are disabled except one. Update speed is normal. And still zeros for all network traffic.

I use no bandwidth control utilities and have Windows up to date. Updating Windows (including windows optional updates) didn't help.

  • Is that Task Manager showing processes from all users?
    – week
    Aug 26, 2013 at 13:33
  • Yes. But how this can matter? Torrent downloads hard while task manager shows zero for it.
    – Dims
    Aug 26, 2013 at 13:49
  • I remember that the Process Explorer from Sysinternals has the same problem. Since the company is now a part of Microsoft maybe the bug is related. Aug 28, 2013 at 14:23
  • 3
    I had this issue, found out that Connectify had installed drivers that conflicted with a hidden Windows 8 driver that detects network usage.
    – Mark Lopez
    Aug 31, 2013 at 20:19
  • 1
    I have the same problem, I think it's related with VirtualBox virtual network drivers, do you have VBox installed, or maybe VMWare? Another possibility is about Hyper-V virtual network adapters.
    – user284678
    Dec 26, 2013 at 13:23

13 Answers 13


Try to use Resource Monitor (A native build-in tool for Windows 8 to monitor system resource)

If you see small difference in network activity, it can be Resource monitor and uTorrent do not use same unit (kB and B) to calculate or just because both not update at the same time

enter image description here

You can run Resource Monitor from your Control Panel\All Control Panel Items\Administrative Tools\Resource Monitor or it is a shortcut in Task Manager window (mark as red underline in my picture) enter image description here

  • 1
    Yes, Resource Monitor works ok, but the question is about Task Manager.
    – Dims
    Sep 1, 2013 at 18:03
  • The sampling shown in diagram is of 60s only. How can we get a custom throughput sample? Aug 30, 2017 at 13:32

In my case, Virtualbox Bridged Networking Driver was the problem.

Just go to Network and Sharing Center. Click on your network. This should show status window. Next click Properties and uncheck "Virtualbox Bridged Networking Driver".

If you have any other bridges try to uncheck them too.

Start Task Manager. That's it.

  • Thanx This solved my problem.
    – Morteza
    Mar 12, 2015 at 14:41
  • WORKS! I turned off IPv6 and Virtualbox Bridged Networking Driver and Determenistic Network Enhancer.
    – Erdinc Ay
    Aug 11, 2015 at 20:55
  • Won't this disable networking from VirtualBox?
    – Dims
    Apr 11, 2016 at 20:09
  • @Dims, bridged networking with the VM Host machine, with those adapters that have it disabled, yes. Sep 9, 2019 at 9:13

If you have any other network adapters (virtual or physical), try disabling them one-by-one. If it suddenly works, you have found the problem adapter. Then, you can disable it if it is unnecessary. (Especially look for NetLimiter or NetBalancer or something such as that).

Another thing to check is if the "Update Speed" checkbox is disabled under the "view" menu. If that happens, the network usage will show 0%.

  • All adapters are disabled except one. Nevertheless network value is zero for all processes. Update speed is Normal.
    – Dims
    Aug 26, 2013 at 13:28
  • This (update speed in view menu) was the issue - it was "paused"for me! Changed to "normal"and I see the n/w traffic now.
    – Deep-B
    Apr 19, 2014 at 15:47

If you have installed any bandwidth-control product such as NetBalancer or NetLimiter, these interfere with the Windows 8 Task Manager display.

You would need in this case to use the Resource Monitor instead, or try a newer version for the bandwidth-control product.

You should also fully patch Windows 8, including optional Windows Update items (especially the ones pertaining to network). Try to find an update for the driver to your network card from the manufacturer's website (or give us its reference so we can see if one exists).

As another remark, if your network adapter is rated as having a very fast maximal bandwidth such a 1 Gbps, Windows might ignore 1 Mbps as being too small a percentage to show. Use the Resource Monitor in this case (or a Task Manager replacement).

  • From your updates to the post, it seems like only my last option might apply to your case. Try to download a file at your maximum possible bandwidth, or use a service such as speedtest.net, to see if the Task Manager does show it or not.
    – harrymc
    Aug 29, 2013 at 11:31
  • Shows zero during speedtest.net. Do you mean you have some values in task manager in network column?
    – Dims
    Aug 31, 2013 at 20:18
  • Not using Windows 8, so no such column. I did manage to find some screen captures on Internet with non-zero values, although they are rare - almost all are always zero. What is your network card and what is its maximum speed as reported by Windows? I saw there was a suggestion to do antivirus scans, and you can also try sfc /scannow.
    – harrymc
    Aug 31, 2013 at 21:11

Its 2021, I got this issue out of nowhere. Got this solution from a reddit user:

Open a Command Prompt and enter the following:

sc config ndu start=auto

After you enter that command, reboot your Computer.

Didn't fix, want to revert? :

sc config ndu start=disabled

then reboot. Hope it helps someone :)

  • Sorry no luck :D
    – Dims
    Dec 9, 2021 at 18:40
  • Perfect! That worked for me in Windows 10. I had to use a command window endowed with admin rights. I did not need to reboot, but just restated task manager.
    – thin
    Jun 6, 2023 at 18:43

I see two possibilities here. One is that you have a 64bit Windows 8, and 32bit BitTorrent; and the Task Manager has problems in identifying traffic from within the 32-bit VDM. If you have a 64bit Windows 8, you can test this hypothesis by installing 64bit bitTorrent.

The other possibility is that bitTorrent is playing tricks with WFP, the Windows Filtering Platform (ex LSP, Layered Service Provider) in order to make good its claim to "optimize bandwidth usage":

BitTorrent auto-adjusts bandwidth usage, based on your network and Internet connection, to ensure fast file delivery. Your downloads run in the background. Which means they’ll never slow down video chats or game play.

In that case, you could try fiddling with bitTorrent's bandwidth usage options to see whether one of those is responsible.

The fact that user Hardy's installation appears to be working proves that there are no inherent problems in either Windows 8 or bitTorrent; this must be a configuration problem (or maybe a conflict with some other installed software. In that case, maybe unistalling bitTorrent and re-installing it, therefore "on top" of whatever network driver and service chain you have, might fix the matter).


I started facing the problem after installing Killer Network Manager or Killer Control Center. Later i removed it completely but it didn't fix the problem. It seems that problem arises when a third party software like Killer Network Manager tries to interfere with Windows NDU (Windows Network Data Usage Monitoring Driver). Both services work by examining packets, and both doing so at the same time can cause conflicts. So third party software disables/stops Windows NDU in order to avoid conflicts.

To enable or re-activate Windows NDU you need to open CMD as Administrator and run the following command.

sc config ndu start=auto

Now reboot the system. NDU should now be set to start automatically and the Task Manager Processes tab should show traffic in the Network column, but the Killer Network Manager might not work properly.


  • Highly underrated answer.
    – Rishav
    Jan 8, 2020 at 10:09

Try installing WinPcap, the latest version, and restarting your system, this might work on your system. Also try installing Microsoft Network Monitor 3.4, and then trying again. (What I mean is install these applications, and then run the Task Manager again, and see if you are lucky.)

Let us all know if any of these solutions work, thank you.

  • I have WinPcap 4.1.3, which is the latest.
    – Dims
    Aug 31, 2013 at 20:16

For me, it is working by disabling the "Connectify LightWeight Filter". No need to disable IPv6 or any other.

Right click start menu -> Network Connections -> Right Click your network (Ex: Ethernet) -> Properties -> In network tab disable/uncheck Connectify LightWeight Filter.

It will immediately reflect in task manager, check in your task manager network tab now.


I have two ethernet adapters installed. I needed to disable the unused one to be able to see the traffic usage through the task manager (search for "Network" -> "Display Network Connections"):

enter image description here

Usually the task manager should list all ethernet adapters, but in my case it displays only the "first" and this seems to be the reason why it did not work.


The fix is simple, go to start---settings---network&internet---status all the way down there is network reset. Click it and restart your computer.

Warning: you might have some previous settings applied, when you will reset your network all previous settings will reset to default.


I just try with Task Manager and I can see it work, although Task Manager result is not best matched with utorrent but it is work.

To explain why the monitor is different from Task Manager and uTorrent. I think result from utorrent is already calculated, it just only count the data you want to receive/send, not include all other data which can use to request tracker, find peer, some maintain data, etc., but Task Manager count it all

Finally, please retry with Task Manager. It is work.

enter image description here

enter image description here


Don't know if this helps but what I did on Windows 8.1 to fix my Network Usage of 0% was right clicking on the Network Utilization Tab under Processes in the task manager and selected Process Name and all of a sudden, my Network Tab displayed real time usage.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .