18

I've noticed that my computer doesn't want to stay in standby or go to standby after x minutes (as set in my Power Options). Running powercfg -requests tells me that my audio driver is keeping my computer awake... "An audio stream is currently in use"... similar to what was seen in question/answers to uTorrent prevents computer from entering sleep state. Except I'm not running uTorrent, nor any torrenting application.

I know I can (and have, for now) set an override with powercfg -requestsoverride "<audio driver name>" system, but I'm more curious about what is keeping an open audio stream. The only applications I have left open while away are Steam and Trillian. My only guess is that Steam is the culprit because it has an entry in the Volume Mixer, but I can imagine that any application that could play audio at any time might have an entry in there, even if it's not currently using an audio stream.

Is there a way to tell which application(s) is currently using an audio stream (and thus keeping my computer awake)? If it is any help, my hardware/driver is Realtek High Definition Audio.

Additionally, and this is probably asking too much, is there a way to keep known naughty applications from keeping the computer awake? For example, as seen in the comments below, Steam was the culprit, but it shouldn't be hogging an audio stream the whole time just for the chance that I get a message. (I'm assuming this is a bug in the latest version of Steam since this was not an issue in the past.) But I don't like having override set for all audio because, e.g., I could have music playing in VLC or something in which case I don't want my computer to standby.

5
  • 1
    Why not just disable one of them and see if it stops? If not, move on to the next. If there's only a couple suspects it shouldn't take long. Jul 31 '13 at 22:46
  • Good point. I killed Steam and the entry in powercfg disappeared. Still curious if there's a "non-lethal" way to tell. Also, would rather not have to close Steam every time I get up from my computer, but also would not like my computer to standby while playing music, e.g., via VLC. I'll add to my question...
    – jpatton
    Jul 31 '13 at 22:49
  • +1 quitting the applications that have entries in the volume mixer seems to get rid of the request, but restarting the applications doesn't necessarily recreate it. FWIW, Steam seems to be pretty well behaved and will only create a request if there is sound playing. My money would be on Flash player, since that appears to persist even if there's no flash elements open anywhere. Maybe try killing Flash after a certain period of idleness?
    – toryan
    Jul 31 '13 at 23:20
  • 2
    In this case, it was definitely Steam. I didn't have browser windows open other than SU's, and quitting Steam made both the mixer and powercfg -request entries go away. Starting Steam brings them back, even if all Steam windows are closed.
    – jpatton
    Aug 1 '13 at 1:12
  • @jpatton I have the same problem. My Chrome although I am not hearing music is using the realtek audio and that is preventing the pc from going to sleep.
    – Devid
    Aug 28 '14 at 20:54
7

You can use Process Explorer to find out what programs are using particular handles and DLLs. Try to look for audioses.dll.

3
  • 2
    A lot of applications have this DLL loaded including multiple system processes so this is not terribly useful.
    – user169771
    Dec 12 '15 at 6:51
  • 1
    Quit the applications one by one and see which one was holding it open. For me, it was Origin, even though I had a list of 10 apps (Chrome, Steam, etc.) that had the driver in use. Nov 13 '16 at 23:00
  • AutomationNation's approach worked for me too. Culprit was Unreal Editor.
    – Timmmm
    Apr 8 '20 at 7:49
1

Another culprit of keeping Windows from entering standby mode due to "An audio stream is currently in use":

The input signal from your microphone is forwarded to your speakers.

Solutions:

  1. Disconnect microphone
  2. Disable listen mode
0

Check for any program presenting an activity indicator for microphone. For example, if the Windows "Sound" properties dialog is open on the "Recording" tab, select another tab or even close the dialog.

1
  • As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – Community Bot
    Oct 6 at 10:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.