(arch, thinkpad x200) just tried to set up a script to switch from "suspend to ram" to "suspend to disk" after 24 hours.

I am using rtcwake for this.

weird problem: rtcwake is not working. If I try something like "rtcwake -s 60 -m mem", my device (thinkpad x200) enters standby, after ~60 sec the a/c-Led blinks a short duration of time, but the device doesnt wake up from standby.

However if I plug ac-cable in and try this again, the device wakes up after 60 seconds.

Does someone have an idea what the difference between ac pluged in and battery is in that case?

Thanks for you help :-)

Boot to BIOS setup menu > Config > Power

Enable - Timer Wake with Battery Operation

That should solve your problem.

  • You made my day! This should be accepted. – mixel Mar 17 '17 at 17:36

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.