1

I have installed ffmpeg from source with --enable-libmp3lame.

Now when I run ffmpeg with:

sudo ffserver -f ffserver.conf & ffmpeg -s 320x240 -f video4linux2 -i /dev/video0 http://localhost:7070/feed1.ffm

I get this output:

[8] 23814
ffmpeg version N-54962-g8720d3a Copyright (c) 2000-2013 the FFmpeg developers
  built on Aug  1 2013 11:25:27 with gcc 4.7 (Ubuntu/Linaro 4.7.2-2ubuntu1)
  configuration: --enable-libmp3lame
  libavutil      52. 40.100 / 52. 40.100
  libavcodec     55. 19.100 / 55. 19.100
  libavformat    55. 12.102 / 55. 12.102
  libavdevice    55.  3.100 / 55.  3.100
  libavfilter     3. 81.103 /  3. 81.103
  libswscale      2.  4.100 /  2.  4.100
  libswresample   0. 17.103 /  0. 17.103
Input #0, video4linux2,v4l2, from '/dev/video0':
  Duration: N/A, start: 77666.594680, bitrate: 36864 kb/s
    Stream #0:0: Video: rawvideo (YUY2 / 0x32595559), yuyv422, 320x240, 36864 kb/s, 30 fps, 30 tbr, 1000k tbn, 1000k tbc
Missing audio stream which is required by this ffm
[8]+  Stopped                 sudo ffserver -f ffserver.conf

How do I specify the webcam audio stream?

1

Your ffmpeg command only outputs video. You need to generate a blank audio:

ffmpeg -s 320x240 -f video4linux2 -i /dev/video0 -f lavfi -i aevalsrc=0 \
-c:a libmp3lame http://localhost:7070/feed1.ffm

Another weird thing in your command line is that you don't encode video. I assume you don't want raw YUV video to be streames, right?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.