I bought an USB sound card. I'd like to set up my Linux desktop so that it prefers the USB device, if it is plugged in and automatically switches as the device is (un)plugged. Is it possible, and how?

  • Debian uses pulseaudio instead. – Braiam Aug 5 '13 at 20:35

Find your card with

$ cat /proc/asound/cards

To get valid ALSA card names, use aplay:

$ aplay -l | awk -F \: '/,/{print $2}' | awk '{print $1}' | uniq

and then create /etc/asound.conf with following:

pcm.!default {
    type hw
    card 1
}

ctl.!default {
    type hw           
    card 1
}

Replace "card 1" with the number or name of your card determined above.

Alternatively, you can change ordering of your cards so your USB card will be card 0 and it will work without editing asound.conf.

  • 2
    I tried your suggestion, but when the USB card is unplugged, audio stops working completely, instead of switching to the built-in card. – Petr Pudlák Aug 11 '13 at 11:29
  • 1
    Using a RPI2, this solution worked for me. Tried all the rest, but nothing worked until I did this one. (Had to use "card 0" on mine). – Rob Gibbons Dec 6 '15 at 3:35
  • 1
    Using the above configuration, sound in youtube on palemoon did not work for me, this config worked: defaults.pcm.card 1 defaults.ctl.card 1 forum.palemoon.org/viewtopic.php?t=9661#p66016 – Aaditya Bagga May 2 '17 at 5:18
  • stucked for this one day! and you just saved my ass! – Md. Alamin Mahamud Jun 8 '17 at 13:39

this is the method for selecting default sound card in Alsa. You may want to install Alsa for this method to work if you are using Pulse Audio.

cat /proc/asound/modules

will list your sound modules .The output of the command will be like this (eg):

0 snd_hda_intel

1 snd_usb_intel

you can pretty easily understand which one is your usb sound card from above.

nano /etc/modprobe.d/alsa-base.conf

edit this alsa-base.conf in such a way that your preferred card has an index =-2 / 0 and the other card has index =-1 / 1 (stick with -2 and -1 )

options snd_hda_intel index=-1

options snd_usb_intel index=-2

in this case usb device is preferred device.

if you are having two differnt cards with same name from the output, like this:

options snd_hda_intel

options snd_hda_intel

issue this command to find out which is which:

cat /proc/asound/cards

then edit modules in this way:

options snd_hda_intel enable=1 index=0

options snd_hda_intel enable=0 index=1

a reboot may be necessary.so you might have to manually switch over your sound cards.

  • What do you mean by "modifying the output"? How can I modify the output? – Petr Pudlák Aug 11 '13 at 9:05
  • i have made necessary changes in the answer.try this version.hope this helps.the methods may vary according to the flavour of linux you use. – Ashildr Aug 11 '13 at 12:50
  • Thank you. How can I verify the setup? I identified the cards, added the appropriate options, rebooted, but I don't see any change - still the internal (intel) card is the preferred one. – Petr Pudlák Aug 11 '13 at 18:14
  • try >options snd-usb-intel enable=1 index=0 (to enable) >options snd-hda-intel enable=0 index=1 (to disable) or >options snd-hda-intel enable=0 index=0 >options snd-usb-intel enable=1 index=1 and reboot – Ashildr Aug 11 '13 at 19:27
  • i.e, enable usb disable the other one using enable =0 or 1,do this vice versa also.i'm not sure which will work for you.reboot is necessary.i wish u solve yor problem – Ashildr Aug 11 '13 at 19:35

I also couldnt get output from my USB device. My cat /proc/asound/modules output was:

0 snd_hda_intel

1 snd_hda_intel

2 snd_usb_audio

I have tried both answer described here which didnt help (with many index combination and lot of restart). I think problem was my USB device initialize after boot-up. Whatever, so my working solution is blacklisting other 2 sound device by updating /etc/modprobe.d/blacklist.conf as:

blacklist snd_hda_intel

The answer from Matija Nalis only half worked for me (alsamixer changed default, but other things like aplay and firefox stubbornly stuck with the wrong default). This example from the debian wiki worked for me (on CentOS-6 laptop):

defaults.pcm.!card Generic_1
defaults.ctl.!card Generic_1
defaults.pcm.!device 0
defaults.ctl.!device 0

For the record: ALSA is poorly documented, and especially this very simple stuff like selecting which card to use is way too hard. Worse, it seems to change between systems. Also, I got that "Generic_1" tag from aplay -l where it comes up as "card 1" in the list. Other people seemed to be using it, so I did the same... what it means I cannot say.

While you can change the default alsa card by editing .asoundrc or the system asound.conf there are a couple of significant issues with this approach.

It's fragile, and requires application restarts to be honored.

If you want to switch cards on the fly then you really need to use a soundserver that abstracts the applications from the soundcard correctly such as pulseaudio.

  • Some applications like Skype beta ignore that though and connect to the default ALSA card. That results in no audio for Skype when HDMI is the first device instead of HDA. – Max N Aug 28 '17 at 16:51

The tools pavucontrol and paprefs might help setting up too, but maybe that's too easy :) or maybe it will just mess up everything you already done.

  • “might”?  “maybe”?  Can you provide some specifics?  Please do not respond in comments; edit your answer to make it clearer and more complete. – G-Man Feb 3 at 21:28

Here is a variant of Matija Nalis and Tel's answers. This is what worked for me:

~/.asoundrc

defaults.pcm.!card 1
defaults.ctl.!card 1

(Odroid C0, Debian Jessie, HDMI audio as card 0 and USB Sound Card as card 1 according to aplay -l)

Note: other methods did not work for me, as /proc/asound/modules does not exist and there is no hdmi audio module to blacklist or put to low priority, it is embedded into the kernel. It seems I would have had to recompile the kernel without hdmi audio support to disable it completely.

  • sudo modprobe $soundcard_driver would do what you desire for /proc/asound/modules – linuxdev2013 Jul 9 '16 at 11:58
  • @linuxdev2013 how could you modprobe a driver that is not modprobe-able? As explained above, it is not a module, it is embedded in the kernel. – astooooooo Jul 10 '16 at 14:10

protected by Community Aug 18 '16 at 0:36

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.