3

I have the following in my .tmux.conf file:

set -g mode-mouse on
set-window-option -g mode-mouse copy-mode
set -g terminal-overrides 'xterm*:smcup@:rmcup@'

In all running sessions, I used C-b :source-file to source this file, and also tried detaching and re-attaching, as well as killing sessions and just launching new ones.

Regardless, at my xterm terminal prompt within an attached session, scrolling with the mouse wheel produces things like this:

user@host ~ $ `H)`H)aH)aH)

and scrolling does not occur.

I am using Ubuntu 12.04. I am using MobaXterm to access a terminal from a Windows machine (this unfortunately cannot be changed). I am using tmux version 1.6.

I've already looked at the following links for solutions to this problem, and none were able to offer any help or clarifying remarks.

4 Answers 4

3

The default scrollback mode is copy-mode, which is activated by ctrl-b [ by default. After typing that you can page up and page down and use arrow keys to scroll back.

I don't have any experience trying to make the mouse do it. But the copy-mode stuff does work, I use it all the time.

The tricky bit is when you leave yourself in copy mode and don't realize it. You can hit q to exit it. I've started cursing at my non-responsive window more than once, only to realize I left tmux in copy mode.

1
  • After pressing ctrl + b [ you can easily scroll by pushing ctrl and using up and down arrows. Mar 23, 2022 at 20:56
2

I struggled with this problem for a long time as well. Most of the tips I read online didn't help, until I used this.

Put this in .tmux.conf:

set -g terminal-overrides 'xterm*:smcup@:rmcup@'
2
  • 2
    I mentioned that I tried this and it did not work. It is listed directly in my question above.
    – user110014
    Oct 8, 2013 at 11:23
  • 1
    Frustrating when people don't read or ignore content in your question. Oct 26, 2014 at 18:54
2

I had this issue for a while and nothing worked but then I finally managed to solve it. I am using MobaXterm from a Windows machine and tmux version 2.6. I created the following ~/.tmux.conf file:

set-option -g mouse on
set -g mouse on
set-window-option -g mouse on

# Start copy mode when scrolling up
bind -n WheelUpPane copy-mode

#Sane scrolling
set -g terminal-overrides 'xterm*:smcup@:rmcup@'

Then I sourced this file in a usual session (not in tmux session):

tmux source ~/.tmux.conf

After that, scrolling up with a mouse wheel (without pressing Shift) worked well in all tmux sessions (it makes tmux enter the copy mode).

1
  • source is a must.
    – Lewis Chan
    Dec 29, 2023 at 8:27
0

Hate to revive an old question, but in case anyone else is wondering in the future.

http://mobaxterm.mobatek.net/download-home-edition.html

Version 8.2 (2015-09-12) Improvement: you can now scroll in Tmux using Shift+MouseWheel if you have the "set-window-option -g mode-mouse on" feature enabled in your ".tmux.conf" file.

You must log in to answer this question.