13

I updated Notepad++ to 6.4.3 this morning. Since then, I've noticed a very strange behavior. Notepad++ now scrolls beyond the EOF, i.e. I'm able to scroll the document even beyond the last line.

Here is a screenshot to show what I'm talking about:

Notepad++ scroll image

Until yesterday, everything was fine and scrolling was not allowed beyond the last line. Suddenly today after updating from version 6.3.3 to 6.4.3, Notepad++ started behaving in this way.

Is this a new default feature? Can it be disabled through any settings?

9
  • didn't you install any plugins lately?
    – Ashtray
    Aug 2 '13 at 8:51
  • 1
    Reinstall it! If this still fails then it may be due to a plugin compatibility issue!
    – Dave
    Aug 2 '13 at 8:55
  • This is common behaviour for most editors if line 35 ends with a CR/LF. Are you sure it's changed behaviour or did a previous instance of the file not have a CRLF after line 35? It would be unusual if you could scroll even further down then line 36, but even that is allowed in some editors (and they will then add empty lines or not).
    – Jan Doggen
    Aug 2 '13 at 9:03
  • 2
    What is odd, that I use the same version right here (updated recently too) and I cannot scroll like that, which I would like to be able to do :)
    – Ashtray
    Aug 2 '13 at 9:10
  • 1
    Do you have the ScrollPastEOF plugin loaded? Aug 2 '13 at 9:57
27

If you update Notepad++ to version 7.0 or above, you'll now also have the option to enable this natively without plugins:

Go to Settings > Preferences > Editing, and check Enable scrolling beyond last line.

Therefore if you see this behaviour on a newer version of Notepad++ and don't want it, you might want to check if that setting is enabled.

2
  • 2
    Thanks! Came here for looking how to ENABLE it in 7.5.8!
    – emery.noel
    Sep 13 '18 at 15:34
  • 2
    This seems to be the preferred solution in my opinion. At this point people really should be using a Notepad++ version above 7.0, and they should also be using a solution that is native / does not rely on a Plugin.
    – Jaxian
    Apr 30 '19 at 9:54
14

This behavior should be controlled by the ScrollPastEOF plugin.

To remove it, open the Plugin Manager and switch to the Installed tab. Find the entry for ScrollPastEOF, select it and click Remove:

enter image description here

4
  • 1
    I think this is also a solution, but it applies if I've installed the ScrollPastEOF plugin. My case, it didn't apply actually!
    – Rahul
    Aug 2 '13 at 10:07
  • 1
    @R.J: Well, I just updated to 6.4.3 as well and couldn't scroll past the end of the file. The changelist on the download page also didn't mention anything. Aug 2 '13 at 10:09
  • 2
    I installed a plugin called Notepad#, which had caused this problem. During re-installation, it showed that it was an incompatible plugin and the setup disabled it, which fixed the issue! Anyways +1, because I never knew that such a plugin existed just to scroll beyond the EOF!
    – Rahul
    Aug 2 '13 at 10:10
  • I found this page while looking for something like the ScrollPastEOF plugin. Thanks for the answer.
    – freb
    May 6 '14 at 17:31
8

It was the Notepad# plugin which was causing this problem.

I reinstalled Notepad++, and when doing so, it said that the Notepad# plugin would be disabled because of an incompatibility. After doing this I can no longer scroll past the last line in the file.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.