Yesterday I've closed my MacBook , opened it today and experienced horrible performance slowdown, beach ball and eventually a freeze.

After several reboots I managed to close most of my applications but the problem presisted. My free disk space is about 11GB. I opened “Spotlight” and saw the file indexing process in progress. After waiting for about half an hour I have decided to turn the indexing off, and did that through terminal.

The slow performance persisted and when I opened the “Console”; I am getting

 PM kernel: disk0s2: I/O error

Every second. As per Google search this is an HD problem. But how and why? Among this error I am also getting a bunch of repeating messages:

Aug 4 22:37:03 MacBook–Air–2 com.apple.launchd[1] (com.apple.iCloudHelper[4459]): Exited with code: 1
Aug 4 22:37:03 MacBook–Air–2 com.apple.launchd[1] (com.apple.iCloudHelper[4459]): XPC Service could not exec(3). Resetting port.
Aug 4 22:37:03 MacBook–Air–2.local PhotoStreamAgent[4455]: AOSKit ERROR: XPC CLIENT: Connection [0x7fa20a54eba0] event handler received event with type: [XPC_TYPE_ERROR]. Description: [Connection interrupted]
Aug 4 22:37:03 MacBook–Air–2.local CalendarAgent[193]: AOSKit ERROR: XPC CLIENT: Connection [0x7fca1b4cfda0] event handler received event with type: [XPC_TYPE_ERROR]. Description: [Connection interrupted]
Aug 4 22:37:03 MacBook–Air–2.local PhotoStreamAgent[4455]: AOSKit ERROR: XPC CLIENT: Error received in reply message (msg=0x7b0f9b30), Description: [Connection interrupted]
Aug 4 22:37:03 MacBook–Air–2.local CalendarAgent[193]: AOSKit ERROR: XPC CLIENT: Error received in reply message (msg=0x7b0f9b30), Description: [Connection interrupted]
Aug 4 22:37:03 MacBook–Air–2 com.apple.launchd[1] (com.apple.iCloudHelper): Throttling respawn: Will start in 8 seconds
Aug 4 22:37:04 MacBook–Air–2 kernel[0]: disk0s2: I/O error.

Anything I can do without formatting my entire HD? I have a ton of Ruby stuff installed which will take a week to install back.

  • Shall we assume you don't have a suitable backup that you can simply restore onto a working disk?
    – Spiff
    Aug 4, 2013 at 19:09
  • Yup. That's what happends whe people live on the edge. Aug 4, 2013 at 19:17

6 Answers 6


There are sometimes ways to get a failing hard drive back to a somewhat more healthy state, but they still take many hours (mostly "unmanned" hours) it goes something like this:

  1. Get a large fast external hard drive big enough to hold a bootable copy of Mac OS X, and still have more free space than the entire capacity of the failing disk. Install Mac OS X (any version that you're absolutely sure will boot your Mac) onto the external drive. Boot from the external drive and unmount the internal drive. Run a tool like SMART Utility to see how many pending, reallocated, or remapped bad sectors (blocks) you have on the failing disk.
  2. Use GNU ddrescue to try to copy as many working sectors as possible from the failing drive into a file on the large fast external drive. Use ddrescue's log file feature to keep track of which sectors were unrecoverable.
  3. Once you've given up on trying to recover the last remaining unrecoverable sectors, use ddrescue to write zeroes to the unrecoverable sectors. These writes will allow the disk to stop using the bad sectors if it can.
  4. Rerun SMART Utility to make sure that it worked; there should be no more pending bad sectors.
  5. If it looks like it worked, try booting off the failing drive. If you were lucky, the bad sectors were in non-critical files.
  6. As soon as you can, make a proper full backup of your drive, TEST YOUR BACKUP, and then reformat the drive WITH ZERO ALL DATA selected so every sector gets written. Then restore from your backup.
  • 1
    I would like to add that I would no longer thrust a disk with an increasing number of bad sectors. So keep monitoring those S.M.A.R.T. values. If they increase then dump the disc in the trash.
    – Hennes
    Aug 4, 2013 at 19:40

It looks like you are seeing the final stages of disk failure. Yes, that's a grim prognosis, but having seen a few hard disk crashes myself I am always extremely wary of any drive that starts throwing I/O errors left right and center. Hard disk drives today have extensive error correction built in; by the time I/O errors bubble up to the OS, it's already quite far gone, especially if it's more than extremely sporadic.

@Spiff has provided good suggestions on how to recover as much data as possible from the drive, and I'd like to add one thing. Get as much data as you can off the drive, then just toss it. Do a full reformat or overwrite the drive with zeroes (or random data) if you are concerned about any privacy implications, but migrate the data to a new drive now and start using that new drive instead of the failing one.

Consumer drives are cheap, and even enterprise grade drives aren't that outrageously expensive per gigabyte. Are you willing to risk all your data to save that money? I don't know what you've got on the computer, but to me, the data is often more valuable than that.

The hard disk you've got may keep working a day, or a year, but when it fails, it will almost certainly fail in some spectacular fashion and it will be at the most inconvenient time imaginable. Save yourself that grief and get a new drive now.


Problem fixed after completely reinstalling Mac OS X. It has been more than 5+ months now and it works great. So no panic and no hysteria.


I just had this experienced recently and I have managed to get it back working to normal. It may well be that the combination of long period of usage and the accumulation of dirt in your computer have caused this error.

I'm not an expert, but I've tried most of the proposed solutions online found in forums (stopped short of getting anything replaced), so the list below is what I think works for my case. I don't know how long will this last, though. So as previous poster said, get everything backed up always.

This is my experience only and I will not be liable if you damage anything in the process!

  1. Ascertain your disk is still accessible. Logon to your bootcamp (if available) and/or use Disk Utility to Verify and Repair. You can use Internet Recovery if you don't have your os dvd, see http:// support.apple.com/kb/ht4718
  2. Unscrew and open up the back of your macbook pro case (you may or may not void the warranty), it's very easy to do so. Clean it up well.
  3. Reset PRAM and SMC. See http://support.apple.com/kb/ph11243 and http://support.apple.com/kb/ht3964
  4. Let it rest for say half a day with everything unplugged.
  5. Try again, and promise to Santa that you'll take care of your computer this time.

As I said this method worked for me and now my machine is even a little smoother. Good luck.


I had this same problem and thought it would be necessary to replace the disk. The Disk Utility "Repair Disk" feature didn't help.

In a fit of desperation I tried erasing the drive and restoring from backup, and I haven't had any disk-related errors since. That was 8 months ago.

  • Phil

Ok, dinosaur here still using a late 2009 MBP with Mavericks, & have seeing same I/O error in console.

Just recently started having boot problems (no boot), & Safe Mode didn't work either.

Got into Recovery Mode (Cmd R at boot), but Disk Utility could not Verify or Repair the disk.

Finally it did boot to Single User Mode (Cmd S after chime), & the following has worked (twice so far) to get me booted, so I could copy off all my data & create a new bootable fresh Mavericks install disk.

In Terminal try the following :

  1. fsck - fy [for me that returned an error saying 'could not repair disk']

  2. /sbin/fsck -fyd [Long process which changed some volume entries, but finally said volume could NOT be repaired after 3 attempts]

2.5 Run 2 again. [ if no joy, go to 3 ]

  1. fsck - fy [ Completed saying 'disk has been repaired']

  2. repeat 3. [ Completed saying ‘The Volume appears to be OK’ ]

  3. If you get the response in 4. from any of the above, type 'reboot' to exit Single User Mode & restart.

The 2nd time I had to do this to be able to boot I went straight to 2. & it worked fine.

I still don't know what the exact problem is, but at least this gets my machine up & working while I try to work that out, & save my stuff.

Good luck.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .