There are about 40 computers at work with this problem. They all have an ASUS P5KPL/1600 motherboard. They are all running SUSE Linux 11.1.

When I tell the computer to shutdown either through the UI or by issuing

shutdown -h now

in a root terminal, the computer wull shutdown for about 1 second and then powers back on again.

I have disabled all the wake on events in the BIOS just to make sure it's not an external event that's causing the computer to restart.

I've tried booting with an Ubuntu live CD to see whether the problem was with SUSE specifically. Shutting down from Ubuntu also doesn't work; the computer just restarts.

The IT guys at work tell me that the same machines (machines with the same motherboard) power down fine when Windows XP is installed.

If I boot the computer, enter the BIOS and save without making any changes, on the next reboot the computer will shutdown and stay off when told to do so from either SUSE or Ubuntu. After that, it goes back to rebooting every time it's suppose to shutdown.

Any ideas as to why I can't power them down with Linux?

3 Answers 3


I asked the IT guys to try removing the PCI/PCIE cards that were installed to see if they were affecting the shutdown process.

Sure enough, removing a Moschip Semiconductor serial/parallel port PCIE device resolved the problem.

  • Stupid question, but I have the same problem (also with Linux), and how can I see if I have Moschip devices in my computer? lspci doesn't show anything by that name. It does show several PCIE devices.
    – Mr Lister
    Jul 29, 2015 at 17:38

I have had cases where even though the BIOS is set to not wake for anything, it still does (especially hard wired NIC - PSU based machines).

Try unplugging your Ethernet Cable, and then shutdown. This will show if it is any sort of "magic packet" that is being sent, even without your knowledge.

  • Hi Will. Thanks your your answer. I tried shutting down without the network cable plugged in and the machine still reboots. Oct 29, 2009 at 22:30
  • Very weird - only other suggestions I would make (but it sounds like you have had a good dig in the BIOS) would be to double check options such as ACPI support, Power saving features, Power Failure options, Suspend mode etc, and if that doesn't help - see if a BIOS update is available. Oct 29, 2009 at 22:42

It's perfectly possible that there's a hardware or firmware flaw. Flashing the BIOS might help. If not, you could actually install Windows (or borrow someone's hard disk running Windows, since these computers have the same hardware) and see if Windows can shut it down.

  • Thanks for the tip Carl. We've tried flashing the BIOS with the latest version and some older versions. Still no go. We've tried booting the machine with the BartPE live Windows CD. Shutting down from Windows works. Strange. Nov 10, 2009 at 22:14
  • There's some difference in the way Linux and Windows are issuing the shutdown command. I'd report this as a bug to Ubuntu, who will probably go up the chain and report it to the kernel developers.
    – CarlF
    Nov 10, 2009 at 23:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.