My current laptop is an HP pavilion g6, windows 7 64 bit.

I had many Pcs before, I used the English keyboard on all of them. If i want to type é for example, I would type ALT-130. On my current laptop the ALT functionality doesn't exist, i tried messing around in the control panel but couldn't fix it.


  • I see no num lock key, that's my keyboard

enter image description here

  • I don't want to transform my keyboard to AZERTY, I want to use the standard English QWERTY keyboard.
  • You can add extra keyboard settings in Windows. Don't use French, that's too weird (AZERTY), but US-international should give you 'e = é – MSalters Aug 5 '13 at 9:51
  • @MSalters I added English international in the control panel and I'm currently using it, should i add something? – Lynob Aug 5 '13 at 11:26

A small utility, called keyxpat, could help you. You just type the E key and keep it pressed until a metronome gives you some beeps (a few milliseconds). Depending when you release it, you get your é, è or ê. Same for all diacritics.

Disclaimer: I'm the author and I use it in the same situation. I'm a french expat in Montreal with a qwerty keyboard.

  • great software! can i exclude characters i don't want? for example the most used accent of e is é and è, the other accents are not used that much therefore, can i just tell the program not to use it? This program works better that the alt + numpad keys! – Lynob Sep 5 '13 at 23:32
  • You can configure all keys and characters in the supplied config file. You need an editor that supports unicode (UTF-8) editing (word or notepad2 that I'm using will do). That way, it's very easy to remove a character, rearrange the order of appearance of the characters or add a complete new set of key/characters. Even if it's easy, I may implement a visual tool to do that in the future... – Nicolas Cadilhac Sep 6 '13 at 0:08
  • cool i love it, when you download it using google chrome, chrome says, it is a potentially harmful application, so you might want to fix that because most users will delete the tool immediately, i scanned it twice just to make sure :) i think you have to fix that issue so chrome won't give warnings – Lynob Sep 6 '13 at 11:44
  • Thank you for the information. I didn't know. However, there is not much I can do since Google uses an algorithm that, in this case, judges more the newness of the web site and the fact that it doesn't have incoming references than the zip file itself. I will add a note for Chrome users though. – Nicolas Cadilhac Sep 6 '13 at 12:18

Firstly make sure you are using only the Numberpad with the Num-Lock key turned on.

Remember also that some programs don't support ALT key functionality, so it might not be a specific problem with your hardware, but might be an issue with the program you're using if that program has changed. If it doesn't work with [Alt] does it work with [Alt Gr]?

If your keyboard has a [Function] key, try holding down the [Function] key with the [Alt] key and typing the number sequence. For example [Function] [Alt] [130] and see if that works.

As a workaround method, although I'm not suggesting you use this as a permanent solution, you could open the Character Map: Start > All Programs > Accessories > System Tools > Character Map and copy and paste the characters manually

Yet a further alternative workaround, which you could use as a permanent solution, is by using Autohotkey and setting up a hotkey to automatically insert a specific character when you push your hotkey, for example you could bind [Alt] [130] to insert [é] - once you set that up, it will function just as well as your [Alt-130] method you were previously using.

  • Nope, Alt+numerical keyboard doesn't depend on numlock. It works on a lower level. That's also why you can't use the numbers on the top row. For the same reason, programs don't influence it either. They're being told what key was entered. Reading the keyboard directly stopped with DOS, in Windows the OS needs to send keystrokes to the right window. (except games, of course) – MSalters Aug 5 '13 at 9:53
  • I'll try autohotkey and let you know – Lynob Aug 5 '13 at 11:27

If you are using the US-International layout and the right Alt key will work as AltGr (although it's not marked as such), you should be able to use the dead key feature. On the United Kingdom extended layout I use, the ´ needs the AltGr key but ` does not. US International may be different. http://en.wikipedia.org/wiki/QWERTY#US-International


The left hand side alt should work but it only works with the numpad keys. You laptop might not have dedicated numpad keys (to save space) but they might have keys with a 2snd fuction. You might have to turn numlock on then look for the numbers on other keys (around the right hand side of your keyboard usually). If not, for just french letters you can hold "alt" and "Ctrl" whilst typing a, e, i, o and u to get á, é, í, ó, ú or you could just hold the alt gr without ctrl for the same thing.

Another solution would be to add the French keyboard layout to your windows. You will then get a language selector near your system tray (bottom right) and can swap between French and English keyboard layout for when you are writing in french. You can also set shortcuts to swap between the 2 different settings.

  • French keyboard is a bad idea; it's non-QWERTY. – MSalters Aug 5 '13 at 9:54

Ok well looking at the picture you are right. You don't have a numpad so will not be able to use the alt + numpad codes. If you don't want to swap to AZERTY either check this link out: http://french.about.com/od/writing/ss/typeaccents_2.htm

It shows using a different QWERTY layout called International Keyboard and also explains the shortcuts you can use to get the different accents.


You can also install WinCompose to help you with such accents and other alt-type key sequences.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.