I'm currently facing blue screens on Windows 7 64-bits, that happen 45 minutes or so after system start-up.

The error code I get is 0xF4, which, according to MS bug check codes corresponds to the CRITICAL_OBJECT_TERMINATION error.

I've tried to analyze the minidump that Windows created, but can't really get what's causing the error. It's said to happen in ntoskrnl.exe which seems to be Windows Kernel process, most of the time at the address 7efc0.

The only clue I have is that it might be associated with my system HDD, which is an Crucial M4 with 64 GB, because when my computer automatically reboot, it gets stuck on

Auto-detecting AHCI device 0

and nothing happens until I reboot manually by completely shutting down my computer.

So my question is, what causes the problem in my case, is it my SSD ?

I have the feeling that it might be this, but then I don't know how to be sure, and then if this is possible to repair that, or if buying a new disk is the only option.

If this helps, I paste the Minidump infos that I got with BlueScreenView :

Dump File         : 080413-27081-01.dmp
Crash Time        : 04/08/2013 22:27:34
Bug Check Code    : 0x000000f4
Parameter 1       : 00000000`00000003
Parameter 2       : fffffa80`0543bb30
Parameter 3       : fffffa80`0543be10
Parameter 4       : fffff800`031d7460
Caused By Driver  : ntoskrnl.exe
Caused By Address : ntoskrnl.exe+7efc0
File Description  : NT Kernel & System
Product Name      : Microsoft® Windows® Operating System
Company           : Microsoft Corporation
File Version      : 6.1.7601.17944 (win7sp1_gdr.120830-0333)
Processor         : x64
Crash Address     : ntoskrnl.exe+7efc0
Stack Address 1   : 
Stack Address 2   : 
Stack Address 3   : 
Computer Name     : 
Full Path         : C:\Windows\Minidump\080413-27081-01.dmp
Processors Count  : 8
Major Version     : 15
Minor Version     : 7601
Dump File Size    : 292 224
Dump File Time    : 04/08/2013 22:29:56

Thanks !

  • Have you tried setting the drive to IDE mode in the BIOS? – trpt4him Aug 5 '13 at 13:19
  • @trpt4him Yep I tried that, but it didn't change anything... I still got a crash. – JBL Aug 5 '13 at 13:24

Had similar problem with 128gb version. Upgrading firmware helped http://www.crucial.com/support/firmware.aspx

  • I'll give a try ! Thanks for the suggestion ! – JBL Aug 5 '13 at 17:13
  • Welp, it didn't change anything, but thanks for the suggestion. – JBL Aug 5 '13 at 18:50
  • upload the .dmp file. The M4 has indeed a 5000 hrs bug which can cause bugchecks. So updating the firmware was a good idea. forums.crucial.com/t5/Solid-State-Drives-SSD/BSOD-Crucial-M4/… – magicandre1981 Aug 5 '13 at 19:02
  • @magicandre1981 Just found out about it, I performed the firmware update thatnks to another version that seems to be newer, and that did the trick. No more crashes. Hell of an hilarious bug from what I read ! Thanks ! – JBL Aug 5 '13 at 22:26
  • ok, great to hear that the firmware update fixed it :) – magicandre1981 Aug 6 '13 at 4:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.