I've tried to install Hyper-v platform component on my Windows 8 Pro. I got no message about anything going wrong. Just after "need restart" i got 30% progress done, then sudden restart again and "canceling unsuccessful install" message. No log messages, or rather say i don't know where to look for it. How could i install a Hyper-V server on W8PRO? which are the system requirements i need to check? I tried also recipe as advised for localized windows here it doesn't job on my W8PRO rus

UPDATE To Question: I 've also tried non-gui dism install of component that way i got the same result first a success message and rollback after reboot. there are a few warnings in dism.log DISM /Online /Enable-Feature /FeatureName: Microsoft-Hyper-V

2013-08-05 23:46:06, Info DISM DISM.EXE:
2013-08-05 23:46:17, Warning DISM DISM Provider Store: PID=5636 TID=1280 Failed to Load the provider: C:\Users\Yuri\AppData\Local\Temp\7A299A5C-6BD7-463C-83B7-E0C41ACF7C97\PEProvider.dll. - CDISMProviderStore::Internal_GetProvider(hr:0x8007007e) 2013-08-05 23:46:18, Warning DISM DISM Provider Store: PID=5636 TID=1280 Failed to get the IDismObject Interface - CDISMProviderStore::Internal_LoadProvider(hr:0x80004002) 2013-08-05 23:46:18, Warning DISM DISM Provider Store: PID=5636 TID=1280 Failed to Load the provider: C:\Users\Yuri\AppData\Local\Temp\7A299A5C-6BD7-463C-83B7-E0C41ACF7C97\Wow64provider.dll. - CDISMProviderStore::Internal_GetProvider(hr:0x80004002) 2013-08-05 23:46:18, Warning DISM DISM Provider Store: PID=5636 TID=1280 Failed to Load the provider: C:\Users\Yuri\AppData\Local\Temp\7A299A5C-6BD7-463C-83B7-E0C41ACF7C97\EmbeddedProvider.dll. - CDISMProviderStore::Internal_GetProvider(hr:0x8007007e)

I think these wornings are not a real cause of failure

UPDATE2 executing dism i go w/o any error up to this point

Deployment Image Servicing and Management tool
Version: 6.2.9200.16384

Image Version: 6.2.9200.16384

Enabling feature(s)
The operation completed successfully.
Restart Windows to complete this operation.
Do you want to restart the computer now? (Y/N) 

I collect all windows\logs\CBS\*.* plus i added a list of ALL enabled windows features

there is a zip link
and raw texts are here

  • 2
    Does your CPU support the required features for Hyper-V? translate the Russian message in the screenshot and a post a screenshot of the error and translate that also post the log file.
    – Ramhound
    Aug 5, 2013 at 19:46
  • Question updated.I have no error about system hardware, but minor warnings.
    – Yurij73
    Aug 5, 2013 at 20:18
  • 1
    upload the folder C:\Windows\logs\CBS as zip to your skydrive, dropbox. I' ll take a look at the logs to see what fails. Aug 5, 2013 at 20:49
  • 1
    @Ramhound this is irrelevant for the issue. Without having the required CPU features the checkbox is disabled. When the configuration fails during reboot it is a Windows servicing issue were you must take a look at the log files. Aug 6, 2013 at 4:26
  • 1
    The CPU has support of Hyper-V ark.intel.com/products/53469
    – Yurij73
    Aug 6, 2013 at 16:50

1 Answer 1


looks like updating the Boot Configuration Data (BCD) fails:

2013-08-06 20:19:56, Info                  CSI    00000025 Performing 1 operations; 1 are not lock/unlock and follow:
  (0)  LockComponentPath (10): flags: 0 comp: {l:16 b:d0395ccac092ce010a00000040044c04} pathid: {l:16 b:d0395ccac092ce010b00000040044c04} path: [l:238{119}]"\SystemRoot\WinSxS\amd64_microsoft-hyper-v-drivers-hypervisor-bcd_31bf3856ad364e35_6.2.9200.16384_none_6e8b90a1724c0f3c" pid: 440 starttime: 130202795702002347 (0x01ce92c0ba94a2ab)
2013-08-06 20:19:56, Error                 CSI    00000026@2013/8/6:16:19:56.720 (F) base\boot\bcd\tools\bcdedit\ai\bcdeditai.cpp(455): Error HRESULT_FROM_WIN32(1006) originated in function Windows::WCP::BcdEdit::BasicInstaller::Uninstall expression: InnerStatus

Error 1006 means this:

# for decimal 1006 / hex 0x3ee
  ERROR_FILE_INVALID                                             winerror.h
# The volume for a file has been externally altered so that
# the opened file is no longer valid.

Make sure the BCD is fine. You can use bootrec to rebuild the BCD:


  • tanks for this, tomorrow I will try rebuild bcd
    – Yurij73
    Aug 6, 2013 at 20:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.