4

I used MS Word 2010 to save a document as a .pdf file, and some of the images have strange, extra lines on them. This happens whether the source document is a .doc file or a .docx file:

enter image description here

Can anyone explain what is happening, and what I can do about it?

Note: I am really looking for an explanation of what is going on with MS Word and how to get it to create my PDF properly, not other programs I can use to create .pdf files from .doc or .docx files.


Edit: When I originally asked this question, I did not know that the source of the image mattered at all, but since I have discovered that part of the issue was the R statistics program generating images with transparency (with no notice to the user), I am adding the R tag to this question. The issue could very well crop up without the use of R, but there are plenty of people out there using R to generate images for use in MS Word and then outputting to PDF, and they should be able to find this question more easily if they are smarter than I am and guess that the source of the image might matter.

  • I know you want to work with Word, but if you get desperate for making PDF files, you can use PrimoPDF (primopdf.com) to make a "printer" that saves to PDFs, and that will work with any program that can print. Not exactly what you're looking for, but I've never had a problem with it, and it's just like printing. – Wally Aug 6 '13 at 14:05
  • @Wally Printing to PDF could work, however when dealing with large documents saving to PDF also gives you the option to automatically create bookmarks which can save hours of work. – Kevin Anthony Oppegaard Rose Aug 15 '13 at 10:29
4

i had this problem, too. it resulted from using the Track Changes feature in the word doc. the lines showed up in the PDF even though the word doc was set to show no changes. You can fix it by going to the Review Menu, click the drop down for Show Markup, and uncheck all of the items (comments, ink, etc.). When I converted again, the lines were gone.

|improve this answer|||||
1

I finally found a solution to this:

  1. Click on the image in the MS Word document

  2. Copy

  3. Open MS Paint

  4. Paste

  5. Save as (new image file)

  6. In the MS Word document, insert the new image in place of the original

...or, in short...

Save the image again, making sure there is no transparency in it, then insert it into the document.

The reason this worked is that the original image contained some kind of transparency layer or some transparent elements, and MS Word was not dealing with those properly. MS Paint cannot handle transparency, and in this case that is actually a good thing, since this means it will always save an image with none, which will play nicely with MS Word's save-to-PDF engine.

The way I found this out was with my first tactic of opening the document in LibreOffice and saving to .pdf from there. That actually did handle the images properly (no strange, extra lines in the output .pdf), but caused other problems (broke some formatting). The big clue that the image was part of the problem is that every time LibreOffice saved to .pdf, it threw an alert that was some kind of warning about image transparency.

A little more background info: I got the original image from R (the statistics program), saving it straight from the graphics window ( File > Save as > Png... ). R apparently generates images with transparency (with no notice to the user).

|improve this answer|||||
1

I have also had this problem using images from R Studio copied as Meta Files. An easy quick fix is to use the "Set Transparent Color" tool in MS Word and select the background color of your figure.

|improve this answer|||||
0

The best way to get rid of this issue is not to save it as pdf but to print it with a pdf printer driver (see e.g. this explanation: http://www.digitaltrends.com/computing/print-pdf-windows/)

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.