1

I've recently deleted a NTFS partition by mistake. I haven't created a new partition in its space (it's unallocated right now).

I tried recovering it using Active@ Partition Recovery software under Windows XP, the program recognised the partition immediately during scan, so I chose to recover it. However, I got "error writing drive" with "access is denied" cause. The program is being run as an Administrator user.

After a bit of googling I figured out it might just be the BIOS' "Boot virus protection", so I started looking for the setting in CMOS setup, but couldn't find any. The motherboard is a Gigabyte M61SME-S2, with an Award BIOS; I searched the manual and there's no reference to boot sector protection whatsoever. I tried flashing the latest BIOS version (version 6 is installed, version 9 is current stable version) with no success (using QFlash my USB drive isn't recognised, and the windows utility exits with no error or success messages, but BIOS is not updated).

I need to recover files in that partition very badly. Is there anything I can do to stop the "access is denied" error, or any other way to recover the partition? Just in case it's useful, I know the start and end sectors, as well as the number of sectors in the partition, of course. Would it be possible to use GParted or a similar tool to re-create the partition with its original (and existing) content?

1

BIOS virus protection was only useful when the OS would have written through the BIOS functions. 32-bit OSs avoid calling the legacy 16-bit BIOS functions except during boot, so BIOSes have stopped boot virus protection. Newer versions of Windows do block MBR write access to active disks on their own.

A deleted partition can be recovered by creating a new partition in its place. My tool of preference is using a Linux live CD (or USB stick) and run cfdisk to recreate the partition. If you want to check (and maybe back up) the data safely from under Linux, then use mount -o ro /dev/sdXX /mnt first, which prevents writing to that partition.

2
  • I can't upvote you twice, so just let me upvote you a couple of times... I actually had a better time using fdisk instead of cfdisk, since I couldn't find a way to enter partition size in sectors in the latter. After mounting as read-only, I backed data up and moved on. – Esteban Aug 7 '13 at 2:40
  • 1
    cfdisk has a [ Unit ] option in the menu at the bottom where you can change between MB, sectors, and (if you really want :-)) cylinders. – Marcel Waldvogel Aug 8 '13 at 7:09
0

Have you tried using partition software from recovery cd? For example http://lifehacker.com/5984707/five-best-system-rescue-discs I personally prefer Hirens bootCD Recover tools section.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.