I successfully ssh-ed to my Ubuntu machine from a PC through both local and over the internet. However, I got no luck with my Mac. I followed all the steps for SSH key gen and configuration and tried to ssh through both local and over the internet but no matter what I try I keep getting the same error message Permission denied. (publickey)

MacBook-Pro:~ mbp$ ssh -vT xxx@xxx.xxx.xxx.xxx
OpenSSH_5.9p1, OpenSSL 0.9.8r 8 Feb 2011
debug1: Reading configuration data /etc/ssh_config
debug1: /etc/ssh_config line 20: Applying options for *
debug1: Connecting to xxx.xxx.xxx.xxx [xxx.xxx.xxx.xxx] port 22.
debug1: Connection established.
debug1: identity file /Users/mbp/.ssh/id_rsa type 1
debug1: identity file /Users/mbp/.ssh/id_rsa-cert type -1
debug1: identity file /Users/mbp/.ssh/id_dsa type -1
debug1: identity file /Users/mbp/.ssh/id_dsa-cert type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_6.0p1 Debian-3ubuntu1
debug1: match: OpenSSH_6.0p1 Debian-3ubuntu1 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.9
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5 none
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Server host key: RSA xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx
The authenticity of host 'xxx.xxx.xxx.xxx (xxx.xxx.xxx.xxx)' can't be established.
RSA key fingerprint is xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added 'xxx.xxx.xxx.xxx' (RSA) to the list of known hosts.
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: Roaming not allowed by server
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey
debug1: Next authentication method: publickey
debug1: Offering RSA public key: /Users/mbp/.ssh/id_rsa
debug1: Authentications that can continue: publickey
debug1: Trying private key: /Users/mbp/.ssh/id_dsa
debug1: No more authentication methods to try.
Permission denied (publickey).
  • Try to connect again with ssh -vvvT to get some extra debugging information. I assume the key you are trying to use is in authorized_keys on the server correctly? What does the ssh/secure/etc. log on the server say about this attempt? – Etan Reisner Aug 6 '13 at 12:18
  • are you sure that you added the mac's public key to the ~xxx/.ssh/authorized_keys file on the server? – umläute Aug 6 '13 at 12:55

Make sure your key is authorized on the server in ~xxx/.ssh/authorized_keys, and make sure you've typed the server address correctly.

Chances are it will be one of those two things.

|improve this answer|||||

You already have an entry in your ~/.ssh/known_hosts for the ip address you are attempting to ssh into, but the key is different.

You need to manually edit ~/.ssh/known_hosts and remove the line that contains the ip address of the server


Run the following to remove the offending key automatically
(changing the ip address to the ip of the ubuntu server of course)

ssh-keygen -R
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy