For some reason, I booted up my work computer today, like I always do, and the batch file I threw in the startup folder to quickly open up all of my applications told me that "chrome.exe doesn't exist". The icon for Chrome that I have pinned to my taskbar shows the Windows "unrecognized file" icon, as shown here (between the VLC and VNCScan icons):

enter image description here

And the shortcut on my desktop, as well (visible title "COO Landin..."):

enter image description here

Also, if I were to click the shortcut on the desktop it says "application not found" BUT if I click the one pinned to the taskbar, Chrome opens right up.

Also, my WebMatrix 3 application, no longer recognizes Chrome as one of the 5 browsers I have installed, so the quick launch option from the WebMatrix IDE no longer shows Chrome (this is particularly annoying, as now, the quickest way to open up my site-in-development in Chrome from the IDE is to quick launch it from another browser and copy the URL or just type it in Chrome every time).

Google Chrome is set as my default browser and I am on a Windows 7 64-bit machine.

I'm hoping that there is an easier solution than to have to uninstall and reinstall Chrome, because that would be a huge pain, especially if this happens again.

Things I have tried

I did a quick reboot to see if that fixed anything, but it does not.

Checked Chrome to make sure I am signed in (not that I think that would make a difference, but it would show something else out of the ordinary happening).

Is there anything I can do to get it to "check again" or should I expect that an update or something re-structured/re-named the folders in which Chrome resides? I could redo the shortcut, of course, but what about for WebMatrix? No option exists to "re-check" for browser installs, AFAIK.

New Info:

I just learned that when I go to "About Google Chrome" to check for updates it says:

Version 28.0.1500.72 m Nearly up-to-date!

Relaunch Google Chrome to finish updating.

Then I click the "Relaunch" button, and it relaunches, comes back up, and says the same thing. I can go on forever just clicking the relaunch button over and over again, but it always just says:

Version 28.0.1500.72 m Nearly up-to-date!

Relaunch Google Chrome to finish updating.

  • Is there anything in the event log showing any issues running the update? Commented Aug 6, 2013 at 14:44
  • @MatthewSteeples Actually, I don't know where to go for the logs (unless you're just talking about the regular Windows logs), but I have found out more about this and will post more in my question. It seems this does have something to do with updates not fully completing (and thus not removing the old version).
    – VoidKing
    Commented Aug 6, 2013 at 15:02
  • I would suggest fixing any registry errors you have relating to shortucts. I know CCleaner can do this pretty easily. Commented Aug 6, 2013 at 15:09
  • @JasonBristol Yeah, I loves me some CCleaner (except the fact that they ABSOLUTELY force you to have a stupid toolbar you have to clean up after install these days, but I already have it installed on mine anyway...). Are you suggesting this because of my workaround or instead of my workaround?
    – VoidKing
    Commented Aug 6, 2013 at 16:16
  • @VoidKing Sorry I should have specified, this was a suggestion for your workaround and the icon issue. Commented Aug 6, 2013 at 16:30

2 Answers 2



I found that there is some kind of a Chrome glitch (as if it were the only one...) that you can read about here: https://code.google.com/p/chromium/issues/detail?id=60876

Seems a workaround (this worked for me) was to browse to the Google Chrome folder (for me it was my username/AppData/Local/Google/Chrome/Application) and delete the old version folder, along with the old_chrome.exe file. Then renaming the new_chrome.exe file back to just chrome.exe.

That seemed to fix everything, except the desktop shortcut icon, which can be easily fixed by making a new shortcut or changing the icon for the existing shortcut manually. Even WebMatrix saw my Chrome install again after this.

It was also suggested that using a registry cleaner (CCleaner is a good one), may help with some of the icon problems, but this had no impact on this situation for me.


Are you running Steam by any chance (as in the gaming client software)? It was locking chrome.exe for me. Stop Steam and restart Chrome. That should do it.

  • For me, no, I do not have Steam installed.
    – VoidKing
    Commented Feb 24, 2014 at 14:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .