2

I'm an avid user of XQuartz and use it for all my computing needs on OS X. Since I essentially don't use any Aqua apps any more, I wondered if it would be possible to start the X window system from console mode on OS X. Figures, I could get rid of the overhead caused by the Aqua window server and I've all the necessary binaries installed in /opt/local/X11 (installed by XQuartz).

First, when logged into console mode (by typing >console as the user name at the Aqua login screen, not by booting into single user mode), I simply tried 'startx': I was faced with an error prompt along the lines of 'cannot connect to server; connection refused'. I then attempted to run 'exec startx', following which I am promptly dropped straight back into the Aqua login screen. Subsequently, if I try to start XQuartz from within Aqua, I get an error message saying a connection to the X server already exists. Grepping all running processes reveals that, indeed, there is an open connection.

I've also tried repeating the processes with common DISPLAY environment variables: :0.0, localhost:0, localhost:X0 (found in /tmp/.unix-X11), etc ... To no avail.

I have the feeling I'm an inch away from my goal but need a last push in the right direction. Hopefully someone knows more about this. I'm running OS X Mountain Lion 10.8.3, for the record.

0

Old question, but an answer for posterity: You cannot.

  1. Xquartz depends on having WindowServer running. It cannot be used outside that environment.

  2. The "console mode" that you're referring to is no longer available in current versions of macOS. (Entering >console at the login screen will typically result in a black, unresponsive screen, and you'll have to reboot.)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.