7

If I run tmux from my cygwin bash shell it prints 1;2c on my prompt after tmux launches. If I attach to a session I had open earlier using tmux attach-session it does the same thing. If I had vim open in that session it will act as if I had typed 1;2c in vim.

I made my .bashrc empty so I know it's being caused by tmux, not my bash settings.

Here is my .tmux.conf

3
  • How did you install tmux in cygwin? Feb 7 '14 at 8:18
  • You can install it from source if you install libevent (and maybe ncurses?) from source too. Just google for instructions and you'll find several posts. The change happened after 1.8 so you need the latest trunk from sourceforge.
    – Philip
    Feb 7 '14 at 15:55
  • 1
    tmux 1.9a1 is now available as a pre-built package in Cygwin. However, this problem is still present using the latest libevent 2.0.21. This SE question has been linked in the cygwin mailing list. Hopefully the issue will be solved soon.
    – Kal
    Mar 5 '14 at 9:43
4

There must be a race condition in tmux on cygwin, because changing escape-time from 0 to 1 fixes it for me most of the time.

For values above 50ms this issue never appears again.

0

For those who have the same problem. It's all about /dev/pts/ permission

Add your user to the tty group with the command :

sudo usermod -a -G tty escaper

And then change permissions:

sudo chmod 730 /dev/pts

or whatever you want but with group writing perm.

Also if you get this problem after make chroot and mount /dev then you can mount dev/pts. So like this :

sudo mount --bind /dev/ /home/jail/dev
sudo mount --bind /dev/pts/ /home/jail/dev/pts
1
  • As the question is about running tmux in Cygwin (on Windows), that is unlikely to help.
    – RalfFriedl
    Jun 23 '19 at 14:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.