I have an old HP pavilion laptop lying around still -it died a few months ago, but the hard drive is fine. I had it fully encrypted with true crypt (pre-boot authentication).

Recently I've purchased a hard drive enclosure. It arrived in the post today and I transferred the HDD from the laptop into the enclosure today. Upon trying to mount it, Windows tells me that I need to format it. I tried accessing it from truecrypt without pre-boot authentication but it claims my password is wrong (note that my password has a UK keyboard character in it - not sure if this is a factor).

So far my attempts to access the data have failed.I'm unsure what else I could try considering I'm certain the password is correct. Sadly I do not have my rescue disk.

  • Can you boot off of the external drive? – Darth Android Aug 7 '13 at 21:40
  • I've tried doing this but it ends up going into a recovery screen for the current laptop... which doesn't make much sense. I'm guessing since it's an enclosure it doesn't spin up fast enough to be recognised and the computer assumes standard recovery procedures. – Andy Aug 7 '13 at 21:43

Upon trying to mount it, Windows tells me that I need to format it.

This is normal Windows behavior when it encounters a partition it does not recognize. Don't do it.

Look in Start -> Run -> diskmgmt.msc and look at the partitions on the external drive. It may have more than one. If the disk is fully encrypted, it's going to be the largest one.

You may try mounting it as a hidden volume if you originally set it up that way.

If you know for a fact you are selecting the right partition, and you are certain that the password is correct, perhaps something in the volume header is corrupt. I think Truecrypt has a function where you can restore it from the backup copy it places at the end of the volume. You might try doing that.

  • I've attempted restoring the header from the backup, however it still claims my password is incorrect. Seeing this, it's made me a bit uncertain, so I've attempted bruteforcing with the password I know. Still no luck... Is there any way I can boot the drive into pre-authentication mode as if I was booting from the dead laptop? I've tried this but the enclosure fails to power that quickly. – Andy Aug 8 '13 at 18:59
  • If you believe the enclosure is the issue, remove the hard drive from it, and attach the drive either to your current system or another directly. I don't think the bootloader is doing anything different than if you mounted it via Truecrypt. I have mounted system-encrypted partitions before when switching laptops through the GUI on another working system. – LawrenceC Aug 8 '13 at 19:41
  • 1
    Unfortunately the enclosure is currently my only way of accessing the drive. However, I think I may know what the culprit is with the password issue. The dead laptop has a UK keyboard - the computer I'm using right now has a US keyboard with the UK keyboard style enabled in Windows. I'm thinking that since my password contained a UK keyboard character, the password I'm typing is not equal to the true password since Truecrypt forces the US keyboard and supposedly handles the converted characters. Could this be the problem? – Andy Aug 9 '13 at 18:35


Write your password in a text file, select all Ctrl+A, copy it Ctrl+Ins, and then paste it Shift+Ins into truecrypt.

Or, if it doesn't work:

Check your TrueCrypt versoin. If it is 6.3a or older, it has an incompatibility issue with newer versions, that can neither use nor decrypt files, so install an old version and use it. If you need to use the new and old versions at the same time, use Linux.

If it does not work, you can try some booting from an external usb drive with Moba Live CD 2.1, or qemu (which moba uses). Be careful in Windows admin mode: do not start the old system more than a few seconds only. Check if the password is right, because the old system and the new one cannot use thesame filesystem at the same time, but the new PC will make the old system BSoD, so if you start the old system, the F8 button need to be used after password. If you see a menu with options such as "reboot safe mode" and "standard normal mode", then it means the password works.

Your Answer


By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.