I am trying to get my headset (Logitech H390) to work on a new linux installation (centos 6.4). Unfortunately I am unable to hear anything from the headset. I have tried several options from the sound configuration window with no result (kmod-alsa installed)

Tried google, but no luck there, since the 2 solutions I found require the kernel to be recompiled.

Is there a simpler solution to this problem?

EDIT: After using the headset I cannot hear anything! Something is definitely wrong with the sound card/and or the drivers.

Any help appreciated

  • Do you have a kernel version that needs to be recompiled? – CL. Aug 8 '13 at 9:17
  • No i don't. I am looking for an alternative solution. – Andreas Aug 8 '13 at 11:36
  • 1
    OT: CentOS may not be a good idea for desktop use. Lots of packages are not up-to-date, and lots of (desktop use) packages are missing from repos. – hexchain Aug 8 '13 at 15:31
  • 1
    Ubuntu, Fedora or OpenSuSE seem like a better option for a beginner. Try starting up pavucontrol or alsamixer in the console. Maybe the volume is just down. – Martin Ueding Aug 8 '13 at 15:39
  • 1
    sound card? do you have one installed? sound cards and USB headsets are two separate audio devices. You might have the sound card enabled and the USB headset disabled. – Keltari Aug 8 '13 at 16:37

Try running

sudo alsamixer
in a terminal, then press F6, select your headset (there should be a list of sound cards) and look at the volume bar.

If there is a 'MM' there, it's on mute. Press the 'M' key to unmute it.

If it's not on mute according to alsamixer, run pavucontrol from a terminal, and a GUI window similar to this should pop up.pavucontrol picture (my choice of styling makes it look a bit weird)

Once you have this window open, go to the configuration tab, and set everything that is not your headset, to "off".

Then, go to the output tab, and check your headset device is not muted, or on "silence".

Select the volume you want, and test it.

If none of that works, you may have missing alsa/pulseaudio dependencies. I don't know what the package manager for CentOS is, but if it's aptitude, you can run:

sudo apt-get -f install

This will satisfy dependencies.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.