10

I have 2 monitors at work (Win 7). I sometimes log into my pc remotely from a single-monitor 'demo' XP computer. In that case, the short cut keys (Windows key+ Shift+ Left/Right Arrows keys) are not working in my demo pc.

If I open any window that goes to another monitor I am unable to access it from the demo PC.

How can I resolve this problem?

  • 1
    What software are you using to remote? – Austin T French Aug 8 '13 at 11:31
  • i am not using any software its default with win 7 os that comes we are using. – G K Aug 8 '13 at 14:51
  • 1
    So you are using RDP / mstsc / remote desktop is what it sounds like, that is certainly software. – Austin T French Aug 8 '13 at 14:57
  • yes, you are right @AthomSfere , I am using that only but I was unable to access my second monitor remotely which has a single monitor. – G K Aug 9 '13 at 4:20
16

It's more like a workaround: In the remote connection window on your demo pc, use Alt+Tab to bring the window to the front, then press Alt+Space, choose "Move" on the popup menu, then use the arrow keys of your keyboard to move the window until you see it.

  • 1
    On windows 10 with remote desktop manager I had to use Alt-Del rather than alt-space to get the move menu to appear – Mike Dec 6 '15 at 11:37
4

Dual Monitor without remote Desktop:

• Use ( Windows Key + Shift + Left/Right Arrow Keys) in order to move from one window to another window in Dual monitor.

Dual Monitor with Remote Desktop:

If you are using Remote Desktop on dual monitor, do following steps in order to move using keyboard

• First, use (Ctrl + Alt + Pause/Break) it will select and resize your Remote Desktop.

• Use (Windows Key + Shift +Left/Right Arrow Keys) in order to move from one window to another window).

• Use Ctrl + Alt + Pause/Break) it will select and full screen your remote desktop.

2

If using 3rd party software is an option, I think TeamViewer 8 supports having multiple displays on the remote end point.

Edit: For the options without having any 3rd party SW, after doing some more googling, there seems to be support already built-in in mstsc.exe using /span or /multimon switches. Depending on the version of Win7 you're running, /multimode might or might not work as "multimon feature only works if the remote controlled computer is running Windows 7 Ultimate/Enterprise or Windows Server 2008 R2 Standard/Datacenter/Enterprise" (quoted from the previous link). Furthermore, since you're connecting from WinXP all this wouldn't work out of the box, but you need to install RDP 7.0 client on the WinXP (which requires WinXP SP3).

  • I donot want to use any more softwares to be taken part to resolve this issue. Is there any thing I can resolve the issue without any third party installations? @zagrisman – G K Aug 8 '13 at 14:52
2

You can either move your application like the above answer mentions

(alt+tab) - to select the application

(alt+space) - to open options

(m) - to start moving

this will not work if the application is already fullscreen. In that case,

use (alt+space) and (R) to restore the application

and then use (alt+space) and (m) combination to start moving

Another way (not sure if this will work on < windows 10) is to use

win+shift+ctrl+(left/right) after selecting the application

0

I use Citrix for the RDC. I was able to see the icon in the taskbar, but not the aplication, even using alt + tab.

To solve the problem, I had to click on the icon in the taskbar, Alt+Space, and select 'Move'.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.