1

Opening Excel (MS Excel 2010) files over the shared network drive (linux samba share) opens up instantly (1 second). That is, unless its not already opened by another user.

If the file is already opened by someone else, I keep getting stuck at the "Downloading filename.xls" for over 7 seconds before I get the Dialog box, asking if I would like to open it up as read only. This happens for pretty much every user in the company.

Any ideas as to how to speed this up?

Running Windows 7 with all latest updates and Office 2010 with SP2.

Many thanks.

1

If the files are shared it should open a little faster but, keep in mind that the server is trying to ensure that the file is updated with all of the latest data to ensure the new person opening the file can see the correct information.

5
  • I understand that, however this problem relates to Office in general not the server. We've tried opening up a txt file using Notepad and there is no slowdown at all. It is Office that checks to see if the file is in use by another user, so therein lies the problem. – Croydon Dias Aug 9 '13 at 4:25
  • 1
    Enable file sharing within the spread sheet or document and this will speed up the process ![Share Workbook][1] [1]: i.stack.imgur.com/7dylV.png – Bmize729 Aug 9 '13 at 5:11
  • Did this help at all or are you still having issues? – Bmize729 Aug 11 '13 at 22:43
  • Unfortunately, I am not able to do that. It says 'Workbook containing tables cannot be shared.' – Croydon Dias Aug 12 '13 at 1:12
  • Ah, easiest way around this. Create a workbook with your tables in it and have it reference the shared workbook. In the shared workbook get rid of the tables and convert them to ranges. This may seem a little redundant or excessive but, it is about the only way around the issue at hand. – Bmize729 Aug 12 '13 at 2:03
0

The issue seems to be samba.

A shared file takes around 7-8 seconds on a networked drive shared on samba.

The same files takes 2 seconds to open on a networked drive shared on Windows Server 2008.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.