I noticed today that there is no longer a "Create new text document" option in my Windows 7 (x64 Ultimate) context menu when I right click. No idea how or when it disappeared, point is it's gone.

After searching Google for people with the same problem I tried following a post in this guide.

But I got stuck right away because I don't see a .txt key in my registry under HKEY_CLASSES_ROOT. I only see a .text but I am not sure if that is the same thing.

13 Answers 13


I gained access to another PC running Windows 7, a computer on which the context menu was intact. I peeked at the registry of this machine and copied exactly what was entered. Doing so resolved the problem on my desktop with the broken context menu.

Following all the instructions listed above, the two Strings within the .txt key that I needed were Content Type and PerceivedType.

So then to recap, if you are facing a similar issue, here is what I did to fix this problem. Hopefully it works for you as well.

(First backup the Registry.)

  1. Open regedit.exe
  2. Expand HKEY_CLASSES_ROOT and look for a .txt key. If none exist, create one.
  3. Within the .txt key, create two new Strings: Content Type and PerceivedType.
  4. (Right click) Modify... and the value for Default should be txtfile.
  5. (Right click) Modify... and the value for Content Type should be text/plain.
  6. (Right click) Modify... and the value for PerceivedType should be text.
  7. Create a new key with the name ShellNew within the .txt key.
  8. Within the ShellNew key, create a new String with the name NullFile.
  9. Within the ShellNew key, create a new Expandable String Value with the name ItemName.
  10. (Right click) Modify... and the value for ItemName should be @%SystemRoot%\system32\notepad.exe,-470

Here are two screenshots of what the final outcome should be:

Enter image description here

Enter image description here

  • 5
    Diddnt really work for me, it seems that windows limits the number of entries on the context menu- I just removed some programs which had added context items and txt showed up. – Hightower Nov 20 '14 at 8:46
  • 5
    To make it work i had to delete all other folders under .txt except ShellNew – emirjonb Jun 6 '15 at 7:40
  • it worked fine here, you just need to log off after making changes to the registry – Remo Harsono Jul 14 '15 at 4:25
  • Worked perfectly on Windows 10, without reboot, after deleting 5 unnecessary other context menu items. – Tamás Bolvári Mar 25 '16 at 8:52
  • 5
    Here, Notepad++ had seemingly changed the default value (at least its value was "Notepad++_file"). Changing it back to "txtfile" did the trick. – Till Kolditz Feb 18 '17 at 13:41

Create a new file with the .reg extension, copy, paste, save and run.

Windows Registry Editor Version 5.00

; clear the key

; and recreate
"Content Type"="text/plain"

; @C:\Windows\system32\notepad.exe,-470
  • 1
    Also, restart explorer afterwards (or just reboot) – dlf Jun 21 '15 at 13:58
Windows Registry Editor Version 5.00


"Content Type"="text/plain"




@="Text Document"














  • 4
    While this may answer the question, it would be a better answer if you could provide some explanation why it does so. – DavidPostill Feb 15 '15 at 9:38
  • Worked for me on Win10, no restart needed. – MTAdmin Dec 9 '17 at 18:41

Microsoft updates sometimes change permissions thereby killing acls for context features. After all these years it still happens to some of us.

  • Go to Desktop-> mouse 2 -> New
  • The populated Context Menu should be present.

If not, see earlier posts and check/fix the registry (great stuff!).
If yes, but not inside folders, then

  • Go to documents-> Mouse 2 -> New
  • If a folder is the only choice you get, then you've been excluded. To fix this make a "New Folder" in Documents, open it and then on a blank space inside that folder Mouse 2 -> Properties-> Security (Tab) -> <user name> -> Permissions for <user name> -> Allow (I recommend "Full Control" for yourself) -> Apply.

I didn't need to reboot. I got this from a brainiac maniac in IT at work, hope this helps you too.


Just add the .txt key yourself and then make sure that the following string value is there:


The shell will use it to decide which items to put on the 'New' menu.

enter image description here

Microsoft has a KB article about it here: http://support.microsoft.com/kb/140333

If you're adding a brand new type (or fixing a broken one) you may need to add another entry to specify the text used. The default entry for the HKCR.txt should be 'txtfile'. Then make sure you have a HKCR\txtfile entry with default entry something like 'Text Document':

enter image description here

Close all instances of Explorer (ideally reboot) and that should work.

  • 1
    I tried all these suggestions and still no create new text document option. I even tried downloading a program mentioned in the other thread linked by Ganesh, the program called ShellNewHandeler. No .txt option in my context. – Matt Aug 9 '13 at 14:18
  • Updated to include information about the 'txtfile' entry. – snowdude Aug 12 '13 at 13:09
  • Thanks for your help. However, for some reason still no context menu entry for text documents. My registry editor screenshot looks identical to yours. Is it possible some sort of software is conflicting causing this? – Matt Aug 18 '13 at 16:44
  • Try creating a dummy key (e.g. for '.tst'). That's how I tested out these instructions. It didn't work for me until I created a tstfile entry and pointed the .tst default key to it. – snowdude Aug 19 '13 at 9:22

I had this same problem, and even though all the registry keys appeared to be correct, the option for a new Text Document stubbornly refused to appear.

Only after also adding an empty text file named empty.txt to my machine's \Windows\ShellNew folder, did the option show up for me. (The "empty" part of the name appears irrelevant -- Windows will look up the file type's friendly name in the registry. But the extension matters.)

Don't ask me why/how/when the file disappeared...or became required, if it wasn't already there at some point. But that last step is what made things work in my case.


1. Click on HKEY_CLASSES_ROOT and look for a .txt in regedit.exe

2. Do export and (keep a copy as a backup) and copy paste the following code.

3. Finally import it as .txt . That's it. It works for me on Windows 10.

//credit goes to blackout1000 http://www.cnet.com/forums/discussions/no-new-text-document-thru-right-mouse-click-menu-52234/

Windows Registry Editor Version 5.00

"Content Type"="text/plain"





@="notepad.exe %1"


Same problem, but all the keys had their correct values. I just changed the value of ItemName to


(That is, using the path where I have Notepad++ installed), and it worked. All my other entries are back in the "New" sub menu.


Here's the correct version:

Windows Registry Editor Version 5.00

"Content Type"="text/plain"




  • 3
    This is virtually a duplicate of Theva's answer. The intention is that each answer provide a solution that is substantially different from what has already been contributed. – fixer1234 Dec 2 '16 at 18:04

Jan's answer is the most complete and accurate, however, as user Hightower mentioned, Windows limits the number of items that can appear in the "New" right click menu.

If you already have more than a few options...remove some that are already there. As soon as I removed the options for Word, Excel and Visio documents, sure enough, the Text Document option appeared.

  • How did you remove them? – Jacktose Mar 8 '18 at 1:10

i use windows10. i solved this way

  1. Click on HKEY_CLASSES_ROOT and look for a .txt in regedit.exe
  2. Find .txt
  3. New -> key. key name is ShellEx

enter image description here


I had the same problem and it happened after installing Notepad++. None of the mentioned solutions resolved this issue for me, however I was able to get it to work when I added the following to the Registry:

Windows Registry Editor Version 5.00

@="Notepad++ Document"




@="\"C:\\Program Files (x86)\\Microsoft Office\\Office16\\msohtmed.exe\" %1"


@="\"C:\\Program Files (x86)\\Common Files\\Microsoft Shared\\OFFICE16\\MSOXMLED.EXE\" /verb open \"%1\""


@="\"C:\\Program Files (x86)\\Microsoft Office\\Office16\\msohtmed.exe\" /p %1"



My problem was that my "New → text file" didn't show up, but I had all the registers correct.

So I had to remove some programs from the list. Apparently Windows has a limit for how many programs to show there... I removed some Microsoft Office files I didn't use on a regular basis, and that worked for me.

  • Removed them how? – Jacktose Mar 8 '18 at 1:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.