2

I have a Lenovo X230 tablet and as of this morning it is exhibiting a very odd problem with the UltraNav system (both touchpad and trackpoint). Upon starting up the machine, they both work normally, right up until the UltraNav utility loads, then they both quit working. The UltraNav utility shows them both as being disabled, and the option to enable them is grayed out. Drivers all show as working normally. It appears that the utility has suddenly decided (as of this morning) to forcibly disable my pointing devices!

Notably, no recent software updates. Nor any settings changes. It was working perfect last night when I shut it down. I turned it on this morning, and here I am! I've rebooted, done complete shutdown/restarts, turned the UltraNav icon on/off, flipped the screen around and tried to reload drivers (it fails, throwing a generic "aborted" message). Still no luck. :-(

EDIT

Note that the touchscreen and the stylus both continue to work.

3

OK, finally found the magic sequence.

  1. Uninstall the hardware driver.

  2. Reboot.

  3. Login, it'll tell you to reboot. Go ahead and do so.

  4. Then, on next boot remove the Lenovo Ultranav software package from add/remove programs.

  5. Reboot.

  6. Run the Lenovo updater to reinstall Ultranav.

  7. Reboot.

    Should be working normally at this point.

3

This didn't work for me on Thinkpad yoga 12.5 - but a lot of people seem to have these issues on all brands with Synaptics drivers.

Tested with removing the actual cable to the trackpad, rebooting -> shutdown, reconnect and boot again -> same issue.

Ultimate solution was to manually update the driver (HAVE DISK method) after downloading and expanding the Thinkpad UltraNAV drivers (in win8.1 -> it will not allow you to just install the Synatic Driver as it's not digitally signed, while I'm sure there's a workaround it's too much work).

Download and install UltraNAV driver from Lenvo (for your OS version) and it will autoexpand (from the installer) to:

C:\drivers\WIN\UNAV\WinWDF\

Before letting the second part of the full UltraNAV install complete (which will fail as it will not find the driver for the touchpad), you will need to go to Device Manager (in win8 -> WinKey+X, then Device Manager), Expand the "Mice and Other Pointing Devices":

If you show an entry for PS2 mouse instead of your trackpad -> Right Click on the PS2 Mouse -> Update Driver Software -> Select Browse My Computer for Driver Software -> SELECT "Let me Pick From a List of Device Drivers" -> HAVE DISK and Browse to the file (or folder) C:\drivers\WIN\UNAV\WinWDF\x64\synpd.inf (or x86 - depending on your need) and select OK.

This method will force the OS to recognize the trackpad (every other method I tried failed - Admin of 12 yrs... it should never be this difficult - this is how you install beta drivers on beta hardware or in this case get around a driver conflict).

Hope this helps.

1
  • Ditto. What a p.i.t.a.
    – RJ Lohan
    Apr 21 '15 at 0:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.