When you run the :make command in Vim, the output will be displayed page by page as if it
was piped to more. I want to disable this. It is irritating to keep pressing the space bar repeatedly especially if the output is very large.
How do I do this?

up vote 2 down vote accepted

I don't observe this behavior, but the corresponding Vim option is:

:set nomore

When on, listings pause when the whole screen is filled. You will get the |more-prompt|. When this option is off there are no pauses, the listing continues until finished.

Also, check your 'makeprg' and ensure that it doesn't contain a pager.

  • I retract my comment(it suppresses the output), yours rules. Alas! the prompts are nomore. ;) – Segfault Aug 9 '13 at 21:46

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.