TL;DR: copied latest usb.inf from my own system to C:\Windows\inf\usb.inf, rebootet, connected deviced, uninstalled the ones which weren't working, reconnected them and driver was properly installed and devices did work again

I've opened my PC and cleaned it from the inside, after I attached it to power again, most of my USB devices are not properly recognized anymore.


How I cleaned my PC:

  • Opened the case on both sides
  • used my vacuum cleaner and sucked out the obvious big chunks of dust
  • used air compression to blow out dust on hard to reach parts
  • used a just-a-tiny-bit-wet rag to remove the rest of the dust

What happened after I powered up my PC again:

  • I forgot to really shutdown my PC and thus ended up and the resume screen (I almost always put the system into hibernation)
  • Mouse & Keyboard both did not work, the mouse pointer appeared on screen
  • I don't remember about the keyboard, but the mouse had power through USB (middle mouse buttons glows) but still didn't work
  • I was able to restart my PC with TightVNC from within my own network
  • Nothing still worked at at this point of course I started disconnected/connected my devices to various ports until I found a combination which worked but found many things not working as expected anymore

What I tried:

  • I removed device drivers of e.g. the hub, removed power from the PC completely for hours, attached again; no change (i.e. made them electrically removed from any power source)
  • I disconnected/connected devices randomly until I realized with 12 USB ports that might not be a good idea, see the approach below

Since my board has 12 USB ports for testing and I've some devices, I created a matrix so don't get lost what I did test and what did work, etc.

Image of the frontside: http://i.imgur.com/aa6Dh5B.jpg , numbered

from left to right: Port 1,2,3,4

Image of the backside: http://i.imgur.com/la3furp.jpg , numbered

  • Black from left/right/top/down: Port 5,6,7,8
  • Yellow (eSata/USB) left/right: Port 9,10
  • Blue (USB 3.0): top/down: Port 11,12

Every port I connected something too, it was always "recognized", which this I mean: Windows always got signaled that "something happened"; no port was from my POV considered "dead".

Devices I tested:

The bold character is their abbreviation the matrix further down

Description for the matrix, headlines:

  • M Mouse
  • K1 Keyboard 1
  • K2 Keyboard 2
  • H Hub
  • HM Hub w/mouse
  • HK Hub w/keyboard (didn't differentiate which)
  • D Dell monitor
  • DM Dell monitor w/mouse
  • DK Dell monitor w/keyboard (didn't differentiate which)

Cell descriptions:

  • Y Yes works
  • YI Yes works, "i"nstalled driver
  • N Didn't work
  • ND Didn't work, but tried to find "d"river
  • NU Didn't work, "u"nknown device

The matrix:

¦  Port   ¦ M  ¦ K1 ¦ K2 ¦ H  ¦ HM ¦ HK ¦ D  ¦ DM ¦ DK ¦
¦ Front   ¦    ¦    ¦    ¦    ¦    ¦    ¦    ¦    ¦    ¦
¦ Port 1  ¦ Y  ¦ N  ¦ N  ¦ Y  ¦ YI ¦ ND ¦ ND ¦    ¦    ¦
¦ Port 2  ¦ Y  ¦ N  ¦ N  ¦ Y  ¦ YI ¦ ND ¦ N  ¦    ¦    ¦
¦ Port 3  ¦ Y  ¦ N  ¦ N  ¦ ND ¦    ¦    ¦ N  ¦    ¦    ¦
¦ Port 4  ¦ Y  ¦ N  ¦ N  ¦ ND ¦    ¦    ¦ ND ¦    ¦    ¦
¦ Back    ¦    ¦    ¦    ¦    ¦    ¦    ¦    ¦    ¦    ¦
¦ Port 5  ¦ Y  ¦ N  ¦ N  ¦ ND ¦    ¦    ¦ ND ¦    ¦    ¦
¦ Port 6  ¦ Y  ¦ N  ¦ N  ¦ ND ¦    ¦    ¦ ND ¦    ¦    ¦
¦ Port 7  ¦ YI ¦ Y  ¦ Y  ¦ ND ¦    ¦    ¦ Y  ¦ Y  ¦ ND ¦
¦ Port 8  ¦ Y  ¦ NU ¦ NU ¦ ND ¦    ¦    ¦ Y  ¦ Y  ¦ ND ¦
¦ Port 9  ¦ YI ¦ N  ¦ N  ¦ ND ¦    ¦    ¦ N  ¦    ¦    ¦
¦ Port 10 ¦ Y  ¦ NU ¦ NU ¦ ND ¦    ¦    ¦ N  ¦    ¦    ¦
¦ Port 11 ¦ Y  ¦ N  ¦ N  ¦ ND ¦    ¦    ¦ N  ¦    ¦    ¦
¦ Port 12 ¦ YI ¦ NU ¦ NU ¦ ND ¦    ¦    ¦ N  ¦    ¦    ¦

Tool to create such a table courtesy of http://www.sensefulsolutions.com/2010/10/format-text-as-table.html , via https://meta.stackoverflow.com/a/139013

Tools I used during testing:

  • USBDeview to have a better insight what's where and quickly remove drivers
  • Windows Device Manager to see if a device was at least detected with their brand name or just "unknown"

Other resources I consulted:

Conclusions so far:

  • Mouse works everywhere
  • Samsung Galaxy Note 2 works everywhere
  • Keyboards only work on Port 7
  • Hub works only on 1 and 2 and only with mouse
  • Dell works only on 7 and 8 and only with nouse (even though keyboards only work on 7)

I've no idea what's going on here.

Update 1:

As @Bob in a comment suggested, I booted with a Debian Live CD. The keyboards worked on every port I connected to.

I think at this point it's safe to assume:

  • it's not an electrical problem per se creating due my cleaning
  • the USB peripheral hardware isn't at fault either


Thanks to @Ian I was able to fix the problem. His suggestion that there's a problem with the file C:\Windows\inf\usb.inf was spot on. Here are my findings:

  • At first I was skeptical about this and although I could verify the file was not present, since I've never heard of it, I didn't wanted to copy files randomly around
  • Ian stayed convincing and I unfortunately hadn't thought about it but I checked another W7 system I'm having access to and I could verify that it had that file
  • I searched my local computer and found various usb.inf files in misc. locations. I copied the one with the latest timestamp from C:\Windows\winsxs\amd64_usb.inf_31bf3856ad364e35_6.1.7600.20934_none_27ac0e3841194697\usb.inf to C:\Windows\inf\usb.inf and rebootet

After connecting the problematic devices they still didn't work, but this time I could deinstall them in the Device Manager, re-connect and this time the driver was properly installed. I did this with keyboard, mouse, hub, monitor and everything seems to work like it always did!

  • 1
    Try booting from a Linux live CD, or even the Windows setup DVD. That way you can confirm if it's a hardware (USB controller, etc.) or software (OS, drivers, etc.) issue. Also, this is a very nice, detailed question! (The table looks funny on mobile, though, so keep in mind that I can't see it right now.)
    – Bob
    Aug 11, 2013 at 9:36
  • Yes, you're right. I booted into a Debian barebones Live CD and keyboards on every port. So it seems to be a Windows driver issue ...
    – mark
    Aug 11, 2013 at 12:35
  • It is not very good to put the "solution" on the "question". Instead you can write your own answer if it is better than existing answer(s). :)
    – Alvin Wong
    Aug 11, 2013 at 13:00
  • @Alvin Wong: I thought about that, but I don't want to take credit for the answer from Ian ...?
    – mark
    Aug 11, 2013 at 13:02

1 Answer 1


I have had similar problems in the past. Each time it turned out that the usb.inf file was missing from C:\Windows\inf. If it is missing, copy it from another computer and reboot.

  • I've no usb.inf in C:\Windows\inf. I've searched my system drive and I found multiple occurrences of usb.inf, mostly in directories named SoftwareDistribution, FileRepository or winsxs . All of them seem to have the exact same size, 42536 bytes. However, unless I get some more information what this is about, I'd rather not blindly copy around such files ...
    – mark
    Aug 11, 2013 at 12:24
  • That is the same size as the usb.inf file on my computer. From what I have read, there may be other copes of the file in other locations on the file system. I have in the past always copied the file from another installation of the same operating system. You can check, if USB is functioning properly on another installation of Windows 7, it will have that file.
    – Ian
    Aug 11, 2013 at 12:35
  • Yes it worked, I've elaborated my findings at the end of my question. Thank you very much! Still, I wonder why this would suddenly occur; why would that file randomly be not there suddenly ...
    – mark
    Aug 11, 2013 at 12:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.