7

I'm running Windows 8 and in the Computer menu, I see a huge list of "media server" network locations of many of the PCs in my network (most running Windows 7).

enter image description here

Is there a way to either locally disable this so I don't see this list every time, or disable this sharing feature on the other computers?

I've tried disabling "Media Streaming options" from the Network and Sharing Center (on my PC), but that had no effect.

Another thing I tried was enabling Media Streaming, but then selecting all the found clients and clicking Blocked in the list of found clients. That had no effect in removing the list either.

I've also attempted disabling the Windows Media Player Network Sharing Service, but alas, the list remains.

I'm starting to believe there's a magic registry key to unbury and flip to a "1", but all the searching I've done has come up empty.

6

I was encountering exact annooying problem and i found the answer in rhis thread: Niyamath Mohammed answer

  1. Press Windows key + E on the keyboard to open Computer folder.
  2. Click on Computer Tab on the top.
  3. Click on Access Media in the ribbon.
  4. Click on Disconnect from Media server and follow the onscreen instructions.

And it worked when i reopened explorer folder.

  • 1
    "Disconnect from Media server" is grayed out. It is not possible to select it. Why would it be enabled, if we never connected to any media server in the first place? – AnT Oct 16 '15 at 22:22
1

In the comments of the mydigitallife link you gave, is an advice by Werner to execute :

sc delete "WMPNetworkSvc"

There is also another advice by the same Werner to search in the registry all occurrences of "WMPNetworkSvc" and delete the "FailureActions" DWORD value.

Have you tried any of them ?

(Execute these with great caution : I advise creating a system restore point first, just in case).

  • Deleting a built-in Windows service appears very unsafe and unnecessary. – usr Jun 3 '17 at 9:13
0

If you stop the Windows Media Player Network Sharing Service in Services, does that help?

  • 1
    After some testing, and some comments reading (mydigitallife.info/…), it looks like Microsoft forces this service to be on even after disabling it altogether. Either way it didn't remove the list of Media locations. – Moses Aug 16 '13 at 12:41
  • Disabling the service works for me. – nergeia Nov 18 '14 at 10:12
  • @Moses But you have to disable it on the machines, which are running the Media Player Network Sharing, not on the machine, where you're listing them I guess. – Dawid Ferenczy Rogožan Oct 12 '15 at 17:22
0

Look in the following location and see if these devices are listed. If they are delete them, and also make sure to turn Media Streaming back off.

C:\Users\USERNAME\AppData\Roaming\Microsoft\Windows\Network Shortcuts
  • Unfortunately, there are no shortcuts listed in that folder. – Moses Sep 17 '13 at 21:59

protected by bwDraco Aug 15 '15 at 23:01

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.