ping google.com is not working in my windows7 cmd prompt. but google is accessible via browsers

below is the snap shot

enter image description here

Note: None of the website in pinging.. all requests are timed out

But the same google.com is working fine in all browsers. below is the snapshot.

enter image description here

Note: I am using wireless connection for accessing internet.

Please help me to resolve this issue . Thanks in advance.

Also, below is the output of pathping google.com enter image description here

  • Can you give a bit of details about your network environment? Is it a corporate lan or home? Do you have a router or proxy connected?
    – Matt
    Aug 14 '13 at 13:39
  • its wifi connection from my mobile to pc . . It was working fine earlier with this network
    – logan
    Aug 14 '13 at 19:45
  • I don't know this is accurate but I've noticed that some of the ISP's in my country use to restrict such access from their end. This is what once an engineer told me when my friend was questioning about the same exact problem... May I ask whether this has happened recently or is it from the beginning??
    – AzkerM
    Jan 14 '14 at 13:57

From the limited information we know about your network setup it appears that something is blocking ICMP requests out. I would take a look at your router and make sure you haven't recently changed a setting to not allow outbound ICMP (which admittedly would be strange) or talk with your provider and see if they are blocking the requests.

I do wonder though if your web browser is working why are you attempting to ping google? Are you having other problems with connectivity (blocked Torrents, FTP, etc?) that may help clarify what is wrong?

It may also help to try a traceroute to see how far that is able to go.

tracert www.google.com
  • 1
    tracert command request failed !
    – logan
    Aug 16 '13 at 4:51
  • PathPing appears to ping each node which of course won't work since ping fails. What is the output from a tracert request?
    – Matt
    Aug 16 '13 at 20:20
  • its timed out . . Any idea ?
    – logan
    Aug 17 '13 at 2:16
  • Can you try connecting directly to your internet without using the wireless router? Basically if possible plug the wire from your DSL or Cable modem directly to your laptop ethernet port and see if you still timeout. That would likely narrow down if it is the router or your service provider blocking the ping.
    – Matt
    Aug 17 '13 at 20:51
  • Now its working if connect through lan. But i want it to work in wireless too.. PFB LAN result C:\Users\Toshiba>tracert www.google.com Tracing route to www.google.com [] over a maximum of 30 hops: 1 * * * Request timed out. 2 106 ms 61 ms 118 ms 3 * * * Request timed out. 4 * * * Request timed out.
    – logan
    Aug 17 '13 at 21:33

You may be experiencing a commonly faced problem of being able to ping domains by their IP address but not by their domain names. In your original ping to Google, the public address returned was I would attempt to ping that IP first before troubleshooting elsewhere.

If it turns out that you're able to ping IP's but not domain names, you will want to look up more on DNS Resolution.

  • 1
    Technically that is wrong because it was able to resolve the address, meaning if it resolved the address its not anything to do with DNS. ICMP is blocked, we need to know the network setup to help.
    – Nick Eagle
    Oct 12 '15 at 18:17

Having encountered a variety of weird Internet problems similar to yours, I will offer the different methods I use that tend to clear up the issue. My knowledge of why they tend to work is at best intermediate, but they tend to resolve issues:

The order is unimportant, as is doing all of them. Any one or a combination of several of them might do it.

All from the command prompt:

::  resets the ipv4 interface
netsh interface ip reset

:: flush and reregister DNs
ipconfig /flushdns
net stop dnscache
net start dnscache
ipconfig /registerdns

:: clear persistent routes
 route print -f

 :: start / restart mrxdav
 net stop netbt
 net stop mrxdav 2>nul
 sleep 60
 net start mrxdav
 net start netbt

 ::  clean the arpcache
 arp -a -d 
  :: I might have the order of the switches backwards and the order matters, so if that doesnt do anything put the -d before the -a

 :: make sure winhttp and webclient  services are running (this is a mystery to me / neither appear necessary, but both have fixed my problem on various occasions)

 net start webclient
 net start winhttp

Finally if still not fixed, restart router and the restart pc. It won't tell you what is wrong, but it will almost certainly fix the problem.


When pinging add "-4" at last. Like "ping google.com -4"

I know it's been 6 years since the questioned is posted. But this may help others.


You are comparing apples and oranges.

Ping and web browsing are two different things. Many websites block incoming pings to prevent excess network load and DoS attacks.

However, I am able to ping those addresses, so it sounds like something is filtering out pings on your side. You might want to try a pathping google.com to see where your pings are getting filtered out.

  • Thanks Keltari. I have given a snapshot of the result of pathping google.com at the bottom of the question. Please see it, it is also failing...
    – logan
    Aug 16 '13 at 4:50
  • you arent able to ping your router. That is very odd... Looks like your router is blocking pings.
    – Keltari
    Aug 16 '13 at 5:02
  • how come its possible ? I was able to ping the sites earlier with same wireless connection. And even i tried blocking antivirus and firewall but no use . Any idea ?
    – logan
    Aug 17 '13 at 2:21
  • 1
    I would check your router's settings for anything that looks like ICMP rules, Block all ICMP requests, ect. If (ICMP)[en.wikipedia.org/wiki/Internet_Control_Message_Protocol] (ping) is blocked by your router, you won't be able to send out any packets.
    – root
    Jan 14 '14 at 13:28

You can try to restart the router.

If that does not do it:

:: reset the ipv4 interface
netsh interface ip reset

:: flush and reregister DNs
ipconfig flushdns
net stop dnscache
net start dnscache
ipconfig /registerdns

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.