8

I configured my "Normal" paragraph style to have 10pt spacing before and after.

Within word tables, however, I would like no (0pt) spacing before and after paragraphs.

The closest I came was by checking the table style paragraph setting called "Don't add space between paragraphs of the same style".

This only works to my satisfaction when I have a normal paragraph before a table. If the table comes immediately after a heading, the first cell still has this annoying spacing.

I know I could manually mark the cells of the offending table and override the paragraph spacing, but shouldn't this be achievable with some pretty straightforward style configuration?

enter image description here

enter image description here

4

After a lot of trial and error I have found a configuration that so far seems to work pretty well:

Standard style: 10pt before, 10pt after

Table style: 'Auto' before, 'Auto' after

enter image description here

And the result:

enter image description here

| improve this answer | |
  • For those who wonder the tickbox in English is "Don't add space between paragraphs of the same style" -- totally not an obvious solution, but works perfectly for me. Thanks! – mgjk Aug 11 '14 at 14:31
  • I had a Master Document messing up the paragraph spacing for a sub-document that was formatted properly. I could edit the Master to fix it, then save it, but when I closed and re-opened the doc... it had overriden the paragraph spacing again!! Took a while to figure out the "Don't add space..." was the issue! Oh so very annoying and tedious. I hate you MS Word, with a passion... – HodlDwon Oct 14 '16 at 2:23
2

Assuming you haven't tried this already, consider creating a separate paragraph style for table Paragraphs. Apply it to the first one, others should follow, or apply globally to the table.

| improve this answer | |
  • Thanks for the suggestion. I am not a 100% sure, but I think I already tried what you're suggesting. I updated my question with a screenshot to confirm. – Reto Höhener Aug 15 '13 at 12:07
0

Create a style for tables that is based on the regular style. "MyTableNormal". Edit the new style to override the spacing options - spacing before 0pt, spacing after 0pt. You'll get no vertical spacing but the table contents will otherwise be styled the same as un-tabled text. If you update Normal to use Arial instead of Calibri or size 9 instead of 11.5, etc., the MyTableNormal-styled table contents will update to match, and keep the right spacing.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.